PDA

View Full Version : KDE 4.2 And Video Display



cloneu2
4th March 2009, 05:49 PM
Greets
I run 2 samsung monitors and 2 Nvidia 9500GT cards. Here is the strange thing about kde..

Using GNOME i can have each monitor on its own card and then have Xinerama inabled. Doing this i have 2 x servers but the desktop spans both monitors. (IE one desktop background streached across both monitors)

Using KDE i have 2 seperate desktops... different pic on each and can not span across with just one pic. Yet if i open firefox or any program for that matter.. I can have it cover both monitors as one window....


I want kde to run like gnome... Well sort of... here is my xorg.conf



# Xorg.conf For DUAL CARD and Dual Monitor Nvidia 9500GT
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" 1680 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/fglrx"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"

Option "Xinerama" "true"
Option "AIGLX" "on"
Option "MultiGPU" "Auto"
Option "DamageEvents" "True"
Option "Composite" "Enable"
Option "RandRRotation" "True"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"

Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9500 GT"
BusID "PCI:1:0:0"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9500 GT"
BusID "PCI:3:0:0"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
EndSection

Section "Screen"

Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "Coolbits" "1"
Option "TripleBuffer" "True"
# Option "SLI" "auto"
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "DamageEvents" "True"
Option "Composite" "Enable"
Option "RandRRotation" "True"
Option "metamodes" "1680x1050_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"

Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "Coolbits" "1"
Option "TripleBuffer" "True"
# Option "SLI" "auto"
Option "TwinView" "0"
Option "DamageEvents" "True"
Option "Composite" "Enable"
Option "RandRRotation" "True"
Option "metamodes" "1680x1050_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection



if i have both monitors on one card then it works as it should spanning both desktops. But i want to use both cards. I sometimes turn on SLI.

Any thoughts or help as always is greatly appreciated

John