PDA

View Full Version : Native Linux Game Problem



cireland0307
4th March 2009, 01:06 AM
Hi all. This problem is solely for linux games on Fedora 10. When I play Windows games using Wine, Crossover, or Cedega, everything is cool. When I try to run a native game; Planeshift, Eternal Lands, Dominions 3 (the three I tried), I get:

Couldn't find matching GLX visual.

Failed to init OpenGL

I have the proper nvidia driver installed...akmod-nvidia. I just don't get this error message. Also when I grep glxinfo, direct rendering says yes. If someone could help me I'd really appreciate it.

Thanks,

Chuck

Hlingler
4th March 2009, 01:20 AM
By any chance, is color depth set to anything other than 24 bpp (aka "TrueColor", "Millions of Colors") ?

V

cireland0307
4th March 2009, 01:29 AM
Nope, that's what it is set for. It happens on both my desktop and my laptop.

Hlingler
4th March 2009, 01:32 AM
Please post output of command;
glxinfo|grep render

NOTE that if the render string says "Software Rasterizer", this quasi-DRI renderer is NOT sufficient to provide true 3D/DRI/OpenGL support.

V

cireland0307
4th March 2009, 01:34 AM
[chuck@ChuckPC ~]$ glxinfo|grep render
direct rendering: Yes
OpenGL renderer string: GeForce 8800 GTX/PCI/SSE2/3DNOW!
GL_NV_depth_buffer_float, GL_NV_conditional_render, GL_NV_depth_clamp,
GL_NV_vertex_program3, GL_NVX_conditional_render, GL_SGIS_generate_mipmap,
[chuck@ChuckPC ~]$

Hlingler
4th March 2009, 01:40 AM
:confused: Hmm... this is odd. Where did you get the NVidia driver?

If the config file /etc/X11/xorg.conf exists, post it.

V

cireland0307
4th March 2009, 01:41 AM
I got it from rpmfusion.

It's the akmod-nvidia one.

cireland0307
4th March 2009, 01:43 AM
# Xorg configuration created by livna-config-display

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Hlingler
4th March 2009, 01:47 AM
OK, which version of the driver (just to be sure) - should be latest.

Try:
Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules/extensions"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
# Option "AIGLX" "on"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
# Option "AddARGBGLXVisuals" "True"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "DRI"
Mode 0666
EndSectionRe- start X11, see what happens....

V

cireland0307
4th March 2009, 01:54 AM
Hi...back again.

Did all of the above, but Dominions 3 is still giving the same message.

I'm pretty new to Fedora, having used the other distributions...Ubuntu, then Debian and Arch and Slack for a bit

Oh, I know what you mean. How do I find out which one I'm using. I think it's 180, but it could be 172. Not totally confident.

Hlingler
4th March 2009, 01:58 AM
rpm -qa|grep -i nvid|sort

should show what we want to see. Quite frankly, I'm baffled as to why this might be happening. Check Leigh's NVidia guide in "Guides and How-Tos" section (http://forums.fedoraforum.org/showthread.php?t=204752), see if anything there helps. Maybe a forum/google search for the keywords: nvidia [dominions] "Couldn't find matching GLX visual"

V

cireland0307
4th March 2009, 02:02 AM
akmod-nvidia-180.29-1.fc10.i686
kmod-nvidia-2.6.27.15-170.2.24.fc10.i686-180.29-1.fc10.i686
kmod-nvidia-2.6.27.15-170.2.24.fc10.i686.debug-180.29-1.fc10.i686
kmod-nvidia-2.6.27.15-170.2.24.fc10.i686.PAE-180.29-1.fc10.i686
kmod-nvidia-2.6.27.15-170.2.24.fc10.i686.PAEdebug-180.29-1.fc10.i686
kmod-nvidia-2.6.27.19-170.2.38.fc10.i686-180.29-1.fc10.i686
xorg-x11-drv-nvidia-180.29-1.fc10.i386
xorg-x11-drv-nvidia-libs-180.29-1.fc10.i386

Here it is. Well, I appreciate your help anyway. Maybe I'll try a reinstall and this time just use the kmod...don't see why it would make a difference though. Thanks again!!!

Hlingler
4th March 2009, 02:04 AM
Hold the bus, there slim!

What's those PAE stuff doin' in there ???

You appear to have multiple conflicting packages installed.

V

EDIT: Please post results:
rpm -q kernel
uname -r

cireland0307
4th March 2009, 02:07 AM
I don't know...if I upgrade a kernel, should I upgrade all of the packages also? Didn't know those were there.

Hlingler
4th March 2009, 02:16 AM
You have vanilla and PAE flavors of the kmod packages mixed. No wonder Xorg is confused - I am.

Please post the requested info.

V

cireland0307
4th March 2009, 02:22 AM
Sorry, I didn't see that.

[chuck@ChuckPC ~]$ rpm -q kernel
kernel-2.6.27.5-117.fc10.i686
kernel-2.6.27.15-170.2.24.fc10.i686
kernel-2.6.27.19-170.2.38.fc10.i686
[chuck@ChuckPC ~]$ uname -r
2.6.27.19-170.2.38.fc10.i686
[chuck@ChuckPC ~]$

Hlingler
4th March 2009, 02:41 AM
OK, since there are no PAE kernels, then erase the PAE kmod-nvidia packages (I saw two IIRC: one plus a debug). Just those two. Re-start X11.

V

EDIT: These two:
kmod-nvidia-2.6.27.15-170.2.24.fc10.i686.PAE-180.29-1.fc10.i686
kmod-nvidia-2.6.27.15-170.2.24.fc10.i686.PAEdebug-180.29-1.fc10.i686

cireland0307
4th March 2009, 05:04 AM
I'm sorry. Basically, I had enough of my stupidity in updating the kernel when I obviously didn't know what I was doing. So, I reinstalled Fedora on both machines. Glad to say, the problem went away....even though I had to play around with xorg.conf to get 3D turned on.

Thanks for all your help!!!