PDA

View Full Version : Old problem but for new solution about compiz under kde4



wargrey
2nd March 2009, 06:56 AM
Maybe someone thought this problem has been talked too much and solved completely, but I still point it up because this is a new problem with old behave.

About two mouth ago, The kde updated to kde4.1.2. The qt4 windows are always maximized without window decoration when compiz enabled. The other windows such as gtk or qt3 are all normally. Disable compiz is also a solution.

So far, the kde4 has updated three times again and the compiz has updated again, but this problem has still exist.

This is my system info:
Dell Inspiron 640m
Fedora 10(2.6.27.15-170.2.24.fc10.i686)
Packages:
emerald-0.7.9-4.fc10.i386
emerald-themes-0.7.9-4.fc10.noarch
compiz-fusion-plugin-screensaver-0.7.9-2.fc10.i386
compiz-devel-0.7.9-4.fc10.i386
compiz-fusion-plugins-extra-devel-0.7.9-4.fc10.i386
compizconfig-python-0.7.9-4.fc10.i386
compiz-fusion-plugins-unsupported-0.7.9-4.1.fc10.i386
compizconfig-backend-kconfig4-0.7.9-2.fc10.i386
compiz-manager-0.6.0-10.fc10.noarch
compiz-fusion-plugins-main-0.7.9-4.fc10.i386
compiz-0.7.9-4.fc10.i386
libcompizconfig-devel-0.7.9-4.fc10.i386
compiz-fusion-plugins-main-devel-0.7.9-4.fc10.i386
compiz-fusion-plugins-extra-0.7.9-4.fc10.i386
compiz-fusion-plugin-peek-0.7.9-4.fc10.i386
compizconfig-python-devel-0.7.9-4.fc10.i386
compiz-bcop-0.7.9-4.fc10.noarch
compiz-gnome-0.7.9-4.fc10.i386
libcompizconfig-0.7.9-4.fc10.i386
compizconfig-backend-gconf-0.7.9-4.fc10.i386
compiz-fusion-release-1-6.noarch
compiz-fusion-plugin-cubemodel-0.7.9-3.fc10.i386
compiz-kde-0.7.9-4.fc10.i386

This is no install problems. All checks are OK.

How could this be? If this is a bug of compiz or qt4?

Thanks!

Sscheme
13th June 2009, 11:53 AM
Uncheck the checkbox located at:
System -> Preferences -> CompizConfig Settings Manager -> Utility -> Workarounds -> Legacy Fullscreen Support

this worked for me give a try ;)