PDA

View Full Version : OOo icons not showing in the KMenu of F10



theAdmiral
2nd March 2009, 06:06 AM
I am running F10KDE, installing OpenOffice.org. Got it installed and I can run files, but there are no icons for any of the OOo programs in my KMenu. Is this a FedoraForum question, or do I need to seek guidance from the KDE forum? If it is a FedoraForum question, can I get an answer, please? (I asked another question about a non-related topic yesterday and nobody ever answered it. It was a simple question, too.)

Thank you,
theAdmiral

Hlingler
2nd March 2009, 06:13 AM
Sometimes, the menu is not updated immediately. Other times, it may require a logout-login again to refresh the KMenus.
If it is a FedoraForum question, can I get an answer, please? (I asked another question about a non-related topic yesterday and nobody ever answered it. It was a simple question, too.)You could legitimately "bump" the question by posting the steps that you have taken towards a fix/answer.

V

P.S. Please remember also that we are all just "users helping other users" and unpaid volunteers. OTOH, there is no rule prohibiting the offering of a bounty for help, and you can make such an offer(s) to encourage responses. :)

theAdmiral
2nd March 2009, 06:17 AM
We can rule out logout-login, I restarted immediately after the installation.

What do you mean it takes a while to get the icons to appear in the KMenu?? Is there a way to *put* them there???

Many thank yous,
theAdmiral

Hlingler
2nd March 2009, 06:19 AM
KMenu=>Settings=>Menu Editor

The RPM(s) may or may not be constructed to update the menu cache(s).

V

theAdmiral
2nd March 2009, 06:24 AM
There is not a "Menu Editor" in either General or Advanced Settings. hmmm. What next?

Thank you,
theAdmiral

Hlingler
2nd March 2009, 06:27 AM
No: On the KMenu, under Heading "Applications=>Settings"

Should read: "Menu Updating Tool"

V

theAdmiral
2nd March 2009, 06:37 AM
I found it, thanks.
theAdmiral

ozjd
2nd March 2009, 06:49 AM
You can get to the full menu edit tool by right clicking on the menu icon in KDE. The menu updating tool just adds items not on the menu.
If you use the menu edit expand the office menu and select the item you want to edit. There is a box on the right side that should show the icon. If it is empty or you want to change it click on it and it brings up the available icons.

theAdmiral
2nd March 2009, 04:02 PM
I tried this, and I got an icon on the menu, but it didn't work. So I entered the directory the program is in in the "work path". It still didn't work. Am I supposed to enter the program in the "work path", too?

theAdmiral

ozjd
2nd March 2009, 09:17 PM
I tried this, and I got an icon on the menu, but it didn't work. So I entered the directory the program is in in the "work path". It still didn't work. Am I supposed to enter the program in the "work path", too?

theAdmiral

What didn't work? Don't change the command and leave the work path blank.

Jamwa
3rd March 2009, 12:25 PM
I think you may have forgotten to install the appropriate redhat-menus rpm package. If you downloaded the oo tar.gz file, there is a folder after unzipping called redhat-menus (or something close to that). Install the appropriate rpm for your system then log in-log out

Jamwa
3rd March 2009, 01:08 PM
The folder is called desktop-integration