PDA

View Full Version : fedora 10 / gnome login is broken



ryantkoehler
1st March 2009, 11:39 PM
Hi

I just installed fedora 10 (on a dell inspirion) and have been playing with it for a few days but have now screwed over the login process and am am stuck! The problem happened after I tried to install some libraries (gd, jpeg, png, zlib as root via "configure" then "make install") and the screen started flashing so I did a hard power cycle and reboot.

The system boots nicely--no errors/warning in the pre-GUI screen display. I get the login prompt window (and an annoying "keyboard" window with "GOK -Alpha" on the top) but when I log in (as myself) the screen immediately goes black then "autodetect...(analog input)" and back to the login prompt......no login!!!

I'm thinking maybe my home directory file structure got messed up? I remember on solaris this was quite a toxic situation but I could boot from CD and then use "fsck" to restore file (systems). I tried booting from CD with linux but still stuck!

Any clues here? Otherwise I guess I'll try to reinstall from the start. I'd be interested in hearing if anything like this has happened to others and what could be the cause....One time is charm but I don't want reinstalling to be part of "using" my system.

Thanks in advance,
-Ryan

JohnVV
2nd March 2009, 12:04 AM
first some VERY BAD NEWS "gd, jpeg, png, zlib" were ALREADY INSTALLED
your build of zilb broke the system .A reinstall will be the fastest and easiest solution
but if you can boot into the install dvd ( using the rescue mode ) - this will not work if all you have is a "live" cd .
and use yum to reinstall that code
after you do " chroot /mnt/sysimage "


yum reinstall zlib libjpeg libpng gd

if you need to build software that needs the headers for those then also install the -devel packages


yum install zlib-devel libjpeg-devel libpng-devel gd-devel

but a reinstall might be a fast fix?

also NEVER RUN ./configure and make AS ROOT
do this


./configure -- prefix=/usr
make
su
( your root password when asked )
make install

ryantkoehler
2nd March 2009, 01:04 AM
Thanks for the reply

Simple system set up so nothing much lost (except for my valueless time ;-) and practice / learning what to watch out for. Perhaps these libraries are not installed unless one chooses the "developer" option--which I should have. The reason I tried direct installation was because of some fedora/gnome messages (which I'm new to) and/or gcc compile link errors (which I've played with before with my and other's code)...perhaps my makefile(s) need a revised link library path for fedora?

Anyway, thanks again and I'm reinstalling (on my linux machine) even as we speak.

Take care,
-Ryan

JohnVV
2nd March 2009, 03:58 AM
if you are going to also build software then it is a good idea to install the dev tools
chack


yum grouplist

and you will find
GNOME Software Development
Development Libraries
Development Tools
System Tools
most of the time just installing


yum groupinstall "Development Tools" "Development Libraries" "System Tools"

will be all that is needed for 90% of the time

also when you build any software please read the output of

./configure --help
most software will want to install in /usr/local , fedora dose not use this ( it can ) so most things will need the "prefix" option
./configure --prefix=/usr