PDA

View Full Version : help with kmod-nvidia



matthewfl
1st March 2009, 10:07 PM
I installed kmod-nvidia from rpmfusion because I read that I need it to use duel monitors, when I restarted to start the kmod. When my computer came back one the first monitor was not working. I then uninstalled kmod-nvidia and restart again and it is still not working. I at least need the first monitor working and getting the second monitor working would be greatly appreciated. Also the computer is a MacBook.

Thanks in advance for any help.
Matthew FL

ozjd
1st March 2009, 10:18 PM
After you install the driver you should find an nvidia utility in your menu (in KDE it is under Administration). You should be able to config your monitors there.

matthewfl
1st March 2009, 11:02 PM
Thanks for the reply but I do not have the user interface. (that is why I am asking) I only can use bash right now so if you know how to do this through bash or the commands line that would be helpful.

JohnVV
2nd March 2009, 12:15 AM
so all you have ,after installing the kmod is a text only login ??
what happens if you type in
startx
and hit enter

Also look at this file ,it might need editing .
from text mode type in


nano /etc/inittab

the last line of the text file it should be
id:5:initdefault:
-- if that line has a 3 in it change it to a 5 and save
-- to save hit " ctrl + o " then " ctrl + x " to quit

if you do need to change that then reboot
also to find the nvidia command type in
system-config-
-- or --
livna
-- or --
nvidia-settings
and hit the " tab" button twice , there will be a listing of possible commands

i am not using the kmod so...

matthewfl
2nd March 2009, 12:22 AM
I just got it working by using system-config-display and then changing in /etc/X11/xorg.conf graphic card type to intel. (I found the setting in a old config file)
But before the screen was just blank and I had to use control+alt+F2 to get to a login.

JohnVV
2nd March 2009, 12:38 AM
so do you or do you not have a driver for your nivida card installed ?
and what is your card ?
if you Do have the kmod installed AND set the xorg.conf to use " intel" AND NOT TO USE THE "nivida"
driver then you might as well take the card out of the computer because you are not using it .