PDA

View Full Version : vmware server 2 on fedora 10 - server not running



dashlevin
1st March 2009, 09:49 PM
Checked some (all?) of the vmware on fedora threads, to no avail.

Install works, config works, no messages in vmware logs, system logs, selinux logs, but VMware infrastructure web access will not connect to the browser, then server hangs when I try to reboot.

Any logs or config files I should check?


I get this far:

- Installed vmware server 2.0.0-122956.i386 on kernel 2.6.27.15-170.2.24.fc10.i686

- run vmware-config.pl and answer all the questions. All the kernel mods load fine.

- System Services show vmware and vmware-core running, but vmware-autostart and vmware-mgmt
are not.

- Nothing in vmware logs, system logs, selinux logs.

- Invoke vmware, deal with the silly cert.

- Then VMware infrastructure web access responds with:
The server is not responding. Please check that the server is running and accepting connections.

- vmware is now so hung that system shutdown hangs issuing a stop to vmware, I must foorce shutdown.

- Nothing in vmware logs, system logs, selinux logs.

nulli_secundus
2nd March 2009, 02:20 AM
Have you tried Virtualbox? Very easy to use and works well on Fedora. Can't help you with the vmware problem, sorry.

petermholmes
2nd March 2009, 03:17 AM
I couldn't get 2.0 to work either. Finally gave up and went back to 1.8 which works fine.

scottro
2nd March 2009, 03:19 AM
Are you sure you want to use 2.0? The reason I ask is that many people, including myself, don't like their new way of doing things and much prefer the 1.x versions.

(For those unfamiliar with 2.0, rather than a console, you go to some web interface, the whole thing requires java to run, and most people seemed to agree with me that it was far more cumbersome than the older version.)

I haven't used it in awhile though--for my relatively simple needs, VirtualBox has been more than adequate, and with their later versions making host networking trivial, I don't need VMware. I suspect there are still more sophisticated uses where VMware is superior, but they aren't things I need, whatever they may be.

dashlevin
4th March 2009, 03:19 AM
First of all, thanks, I did find an earlier post that addressed my problem,- vmware is incompatible with selinux; disabled it and vmware2 runs (with the horrible new gui), but usb support is hosed and I cannot install their "vmware tools" accelerator software. So I'm stuck again.

Will VirtualBox run the vmware images or do I have to convert the VM image to a new format?

Actually, I'm reconsidering the whole FC10 thing, too unstable. Moved to FC10 because Xserver crashes on my FC6 install; lots of other pain too.

Moved to FC10 and it wouldn't recognize my kbd (recently fixed); last night's system updates broke kbd input for wine applications.

Thanks for listening.

scottro
4th March 2009, 03:25 AM
Well, that's Fedora. Remember, it's kind of a testing distro in many ways, and stuff happens. From what I'm hearing Ubuntu has similar issues from time to time, but that's hearsay.

If stability is the name of the game, you might want to wait a few weeks for CentOS 5.3. It will be stable, but of course, it runs older versions of packages. It's always a tossup.

I believe there's a way to convert to VBox images, but I'm afraid I don't know it, and don't know how well it works in reality.

marcrblevins
4th March 2009, 03:35 AM
Fedora not stable?
Please run full yum update. Then report is you still have issues. My Fedora is running smoothly. I have yesterday's and today's updates installed.

dashlevin
4th March 2009, 03:49 AM
Let me be clearer.

FC10 is stable, especially compared to my old FC6 build, but (my guess is that) the most recent kernel update, kernel-2.6.27.19-170.2.35.fc10.i686 just broke wine input for me.

I shouldn't complain. Last week's kernel fixed a long standing FC10 bug with multi-media keyboard input.

dashlevin
4th March 2009, 03:58 AM
As for vmware2 vs. vmware1.0.8, I tried 2 for the USB support. Silly me.

I will try 1.0.8, but so far the any_to_any patch is not working for me. (2.0 installs without it)

VirtualBox is looking better and better.