PDA

View Full Version : Bittorrent wont open



Fabio Kullock
1st March 2009, 09:37 PM
My bittorrent isnt opening. I dont get an error message or anything, it just doesnt open. I tried reinstalling both from "Add/Remove Software" and from the internet, and doing updates checkup (yum cleanall --enablerepo=updates-testing and yum update etc etc.).
This started to happen right after i started a new download, and it closed bittorrent and started giving an error on boot when i tried to reset my pc. I fixed that but cant fix bittorrent. Any ideas on what to do?

A different problem im having is flash player. I've already installed it (and it shows on "Add/Remove Software") but i still cant get it to work. Firefox still asks for the addon when i open pages that needs it (and yes, i've already tried yum-complete-transaction)

JohnVV
2nd March 2009, 12:32 AM
witch bittorent client ??
KDE installs ktorent by default
Gnome installs transmission by default
i use kotrent and OneSwarm

what is the error when you start it from the terminal
for me i would run


ktorrent
ktorrent(10462)/kdeui (K*Gesture*) KAction::setGlobalShortcut: Attempt to set global shortcut for action without objectName(). Read the setGlobalShortcut() documentation.
Calling appendChild() on a null node does nothing.

that little bit of output is normal if there were an error it will display the error

Fabio Kullock
2nd March 2009, 08:03 PM
Its gnome bittorrent. How do i start it from the terminal?

stefan1975
2nd March 2009, 08:07 PM
fire up a terminal and type:



$ transmission &


stefan

Fabio Kullock
2nd March 2009, 08:36 PM
"$: command not found", but nvm..... installed qbittorrent from add/remove software and its working. But my problem with flash remains. Tried following the steps from FAQ on how to install it but it didnt work.

rpm -Uvh http://linuxdownload.adobe.com/adobe-release/adobe-release-i386-1.0-1.noarch.rpm:
"package adobe-release-i386-1.0-1.noarch is already installed"

yum install flash-plugin nspluginwrapper.{i386,x86_64} pulseaudio-libs.i386 alsa-plugins-pulseaudio.i386 libcurl.i386:
"Transaction Check Error:
package libtasn1-1.8-1.fc10.x86_64 (which is newer than libtasn1-1.5-1.fc10.i386) is already installed
package gtk2-2.14.7-7.fc10.x86_64 (which is newer than gtk2-2.14.7-1.fc10.i386) is already installed
package cups-libs-1:1.3.9-8.fc10.x86_64 (which is newer than cups-libs-1:1.3.9-6.fc10.i386) is already installed"

but when i try "mozilla-plugin-config -i -g -v" it says
INFO: /usr/lib/nspluginwrapper/npviewer isn't accessible.
INFO: /usr/lib64/nspluginwrapper/npviewer looks ok.
INFO: Processing /usr/lib/mozilla/plugins -> /usr/lib/mozilla/plugins-wrapped
INFO: Processing /usr/lib64/mozilla/plugins -> /usr/lib64/mozilla/plugins-wrapped
INFO: Wrapping /usr/lib64/mozilla/plugins/libvlcplugin.so to /usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.libvlcplugin.so...
INFO: Running: /usr/lib64/nspluginwrapper/npconfig
INFO: /usr/lib64/nspluginwrapper/npconfig
INFO: -n
INFO: -p
INFO: nswrapper_64_64
INFO: -d
INFO: /usr/lib64/mozilla/plugins-wrapped
INFO: -i
INFO: /usr/lib64/mozilla/plugins/libvlcplugin.so
INFO: Linking /usr/lib64/mozilla/plugins/libtotem-cone-plugin.so to /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib64/mozilla/plugins/libtotem-gmp-plugin.so to /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib64/mozilla/plugins/libtotem-mully-plugin.so to /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.so...
WARNING: Failed.
INFO: Wrapping /usr/lib64/mozilla/plugins/mozplugger.so to /usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.mozplugger.so...
INFO: Running: /usr/lib64/nspluginwrapper/npconfig
INFO: /usr/lib64/nspluginwrapper/npconfig
INFO: -n
INFO: -p
INFO: nswrapper_64_64
INFO: -d
INFO: /usr/lib64/mozilla/plugins-wrapped
INFO: -i
INFO: /usr/lib64/mozilla/plugins/mozplugger.so
INFO: Linking /usr/lib64/mozilla/plugins/libtotem-basic-plugin.so to /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib64/mozilla/plugins/librhythmbox-itms-detection-plugin.so to /usr/lib64/mozilla/plugins-wrapped/librhythmbox-itms-detection-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib64/mozilla/plugins/libjavaplugin.so to /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so...
WARNING: Failed.
INFO: Linking /usr/lib64/mozilla/plugins/libtotem-narrowspace-plugin.so to /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so...
WARNING: Failed.
INFO: Processing /usr/lib/mozilla/plugins -> /usr/lib64/mozilla/plugins-wrapped
INFO: Processing /usr/lib/mozilla/plugins <- /usr/lib/mozilla/plugins-wrapped
WARNING: I can't open dir /usr/lib/mozilla/plugins-wrapped
INFO: Processing /usr/lib64/mozilla/plugins <- /usr/lib64/mozilla/plugins-wrapped
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.libvlcplugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/librhythmbox-itms-detection-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.mozplugger.so...
INFO: Processing /usr/lib/mozilla/plugins <- /usr/lib64/mozilla/plugins-wrapped
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.libvlcplugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/librhythmbox-itms-detection-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so...
INFO: Checking plugin installation /usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.mozplugger.so...

I downloaded the pluggin from the internet, but i tried deleting it and installing from terminal but it didnt do much

stefan1975
2nd March 2009, 08:44 PM
"$: command not found"

sorry, you don't type the "$" it is your SHELL prompt for a normal user whereas "#" is the shell prompt for root (so in case you accidentally cut and paste a wrong root command it isn't executed because # means 'commented out').

stefan

stefan1975
2nd March 2009, 08:47 PM
it seems you are running Fedora 64bit. why not remove *all* nspluginwrapper stuff and all flash stuff and install the native x64 flash plugin. Use leigh's rpm for this and you should be all set:

http://forums.fedoraforum.org/showthread.php?t=205642&highlight=flash+x86_64

stefan

Fabio Kullock
2nd March 2009, 08:49 PM
well now it gets really odd
Opening it from the terminal worked, and i can run it like that but it says this in the terminal:
(transmission:4487): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Fabio Kullock
2nd March 2009, 09:03 PM
Alright flash thing worked!!
Thanks for the insight :)
Gonna use qbittorrent from now on since i cant get the other one to work :P