PDA

View Full Version : Autologin Works; Cannot Log Out



vahnx
28th February 2009, 06:30 PM
I've set-up auto login so when I boot I don't have to type my password. But now when I log off or switch users it will log me back in right-away unless I log off/switch users twice in a row! Is there a perma fix so it will auto-login only at boot? Thanks in advance. Here's my /etc/gdm/gdm.schemas


<gdmschemafile>
<schemalist>

<schema>
<key>daemon/User</key>
<signature>s</signature>
<default>gdm</default>
</schema>
<schema>
<key>daemon/Group</key>
<signature>s</signature>
<default>gdm</default>
</schema>
<schema>
<key>daemon/AutomaticLoginEnable</key>
<signature>b</signature>
<default>true</default>
</schema>
<schema>
<key>daemon/AutomaticLogin</key>
<signature>s</signature>
<default>drew</default>
</schema>
<schema>
<key>daemon/TimedLoginEnable</key>
<signature>b</signature>
<default>false</default>
</schema>
<schema>
<key>daemon/TimedLogin</key>
<signature>s</signature>
<default></default>
</schema>
<schema>
<key>daemon/TimedLoginDelay</key>
<signature>i</signature>
<default>30</default>
</schema>

<schema>
<key>security/DisallowTCP</key>
<signature>b</signature>
<default>true</default>
</schema>

<schema>
<key>xdmcp/Enable</key>
<signature>b</signature>
<default>false</default>
</schema>
<schema>
<key>xdmcp/MaxPending</key>
<signature>i</signature>
<default>4</default>
</schema>
<schema>
<key>xdmcp/MaxSessions</key>
<signature>i</signature>
<default>16</default>
</schema>
<schema>
<key>xdmcp/MaxWait</key>
<signature>i</signature>
<default>15</default>
</schema>
<schema>
<key>xdmcp/DisplaysPerHost</key>
<signature>i</signature>
<default>2</default>
</schema>
<schema>
<key>xdmcp/Port</key>
<signature>i</signature>
<default>177</default>
</schema>
<schema>
<key>xdmcp/HonorIndirect</key>
<signature>b</signature>
<default>true</default>
</schema>
<schema>
<key>xdmcp/MaxPendingIndirect</key>
<signature>i</signature>
<default>4</default>
</schema>
<schema>
<key>xdmcp/MaxWaitIndirect</key>
<signature>i</signature>
<default>15</default>
</schema>
<schema>
<key>xdmcp/PingIntervalSeconds</key>
<signature>i</signature>
<default>15</default>
</schema>
<schema>
<key>xdmcp/Willing</key>
<signature>s</signature>
<default>/opt/gnome/etc/gdm/Xwilling</default>
</schema>

<schema>
<key>xdmcp/EnableProxy</key>
<signature>b</signature>
<default>false</default>
</schema>
<schema>
<key>xdmcp/ProxyXServer</key>
<signature>s</signature>
<default></default>
</schema>
<schema>
<key>xdmcp/ProxyReconnect</key>
<signature>s</signature>
<default></default>
</schema>

</schemalist>
</gdmschemafile>

vahnx
3rd March 2009, 11:59 PM
*bump*...........