PDA

View Full Version : yum segmentation fault



blittle
27th February 2009, 11:24 PM
so I'm working on a really old system running fedora core 6 (weeeeeeeee) and I'm trying to install about 80 packages for dependencies and I keep getting a yum segmentation fault.

I've tried deleting all the db files and rebuilding the db but it still no workie.

this is a purpose built system so the OS has a bunch of stuff stripped out of it, it's a set-top box basically that runs fc6 and has a tuner card and all that neato stuff in it.

I'm trying to install NX so I can access a GUI on it remotely (without using vnc)

yum.log isn't really saying anything usefull, I"ve tried installing the rpm files from my yum cache without any luck (rpm gives me the same error)

so um, any other ideas anyone?


por ejemple

[root@localhost packages]# rpm -Uvh libgcc-4.1.1-30.i386.rpm
warning: libgcc-4.1.1-30.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Preparing... Segmentation fault


le'sigh

JonathanR
28th February 2009, 12:19 AM
Try this: http://www.rpm.org/max-rpm/s1-rpm-checksig-using-rpm-k.html#S2-RPM-CHECKSIG-NOPGP-OPTION

blittle
28th February 2009, 01:07 AM
that didn't help

Demz
28th February 2009, 02:18 AM
did you try it this way?
yum --nogpgcheck localinstall filename.rpm