PDA

View Full Version : Nimbus theme problems



PolywogSys
26th February 2009, 11:47 PM
I can compile and get nimbus-0.1.7 installed, but the problem is when I choose the nimbus theme (via Appearance in Gnome) the "Controls" or Widgets get unthemed, and an error displays: "This theme will not look as intended because the required GTK+ theme engine 'nimbus' is not installed."
The window manager theme seems to install OK, it's just the controls.

k0428
12th December 2010, 07:29 PM
I had the same problem and fought with it for half an hour before I figured out a way to get this working. :eek:

I downloaded the source package from http://dlc.sun.com/osol/jds/downloads/extras/nimbus/. At this time it was 0.1.4 (btw, how did you get 0.1.7?).

I followed the install steps at http://iexcel.wordpress.com/2009/01/26/nimbus-on-fedora/, which are probably pretty close to the ones that you followed. Just a note though: I don't think that you need to perform all the copying of the intltool things (Does anyone know for sure?), but it might be good just in case. I think it matters what version of nimbus and Fedora you are trying to stick together -- older versions of nimbus might have problems with older versions of Fedora?


This is where I got the same error: "This theme will not look as intended because the required GTK+ theme engine 'nimbus' is not installed."


My solution was to download the rpm for from OpenSuse (sorry, I'm still hailing from the OpenSuse camp most of the time :D), which can be found at http://software.opensuse.org/search?q=nimbus. Just scroll down past the icon themes until you arrive at "gtk2-engine-nimbus" and choose your architecture (i586 or x86_64). Fedora will ask you if you want to install the package, push yes, enter the root password when it prompts you, click the dialogs and the engine should be installed. This seemed to kill the warning, and the theme now works in its fullest! (Still, I'm surprised that the OpenSuse package worked out of box for Fedora, anyone know anything about that?)

If you want to skip the package search page, here are the direct links
i586 (http://software.opensuse.org/search/download?file=openSUSE%3A%2F11.2%3A%2FContrib%2Fst andard%2Fi586%2Fgtk2-engine-nimbus-0.1.3-1.1.i586.rpm&query=nimbus)
x86_86 (http://software.opensuse.org/search/download?file=openSUSE%3A%2F11.2%3A%2FContrib%2Fst andard%2Fx86_64%2Fgtk2-engine-nimbus-0.1.3-1.1.x86_64.rpm&query=nimbus)


I am using Fedora-14 to do this, so I cannot say if this will work elsewhere.

Hopefully this helps out everyone trying to get Nimbus on Fedora, as right now a lot of instructions are for Ubuntu and Debian based installations.


Good luck!