PDA

View Full Version : trouble logging into kde-4.2 on fedora 10 after recent yum update



paladin_zero
26th February 2009, 06:54 PM
I have been using kde-4.2 on fedora 10 for a couple weeks now, keeping up with yum updates. On February 25 yum performed these updates, after which I rebooted the computer and discovered I could not log in to the desktop anymore:


Feb 25 09:49:54 Updated: 2:gimp-libs-2.6.5-1.fc10.i386
Feb 25 09:50:03 Updated: 2:gimp-2.6.5-1.fc10.i386
Feb 25 09:50:03 Updated: libgcrypt-1.4.4-1.fc10.i386
Feb 25 09:50:05 Updated: system-config-printer-libs-1.0.15-1.fc10.i386
Feb 25 09:50:07 Updated: gvfs-1.0.3-5.fc10.i386
Feb 25 09:50:07 Updated: 2:gimp-help-browser-2.6.5-1.fc10.i386
Feb 25 09:50:08 Updated: 1:autofs-5.0.3-41.i386
Feb 25 09:50:13 Updated: scipy-0.7.0-0.1.b1.fc10.i386
Feb 25 09:50:13 Updated: 6:kdelibs-common-4.2.0-15.fc10.i386
Feb 25 09:50:13 Updated: xorg-x11-server-common-1.5.3-13.fc10.i386
Feb 25 09:50:14 Updated: system-config-printer-1.0.15-1.fc10.i386
Feb 25 09:50:22 Updated: eric-4.3.0-1.fc10.i386
Feb 25 09:50:29 Updated: 6:kdelibs-4.2.0-15.fc10.i386
Feb 25 09:50:30 Updated: 6:kdemultimedia-libs-4.2.0-3.fc10.i386
Feb 25 09:50:42 Updated: 6:kdemultimedia-4.2.0-3.fc10.i386
Feb 25 09:50:44 Updated: xorg-x11-server-Xorg-1.5.3-13.fc10.i386
Feb 25 09:50:44 Updated: rpm-libs-4.6.0-1.fc10.i386
Feb 25 09:50:45 Updated: kaffeine-libs-0.8.7-3.fc10.i386
Feb 25 09:50:46 Updated: rpm-4.6.0-1.fc10.i386
Feb 25 09:50:48 Updated: kaffeine-0.8.7-3.fc10.i386
Feb 25 09:50:49 Updated: rpm-build-4.6.0-1.fc10.i386
Feb 25 09:50:50 Updated: rpm-python-4.6.0-1.fc10.i386
Feb 25 09:51:13 Updated: rpm-4.6.0-1.fc10.i386

I have tried moving .kde to .kde.backup and logging in, I've tried changing video cards (all ati), I've tried using radeon, radeonhd and fglrx drivers, I've tried using various suggestions for xorg.conf, I've tried restarting X with no xorg.conf, and I can't track down the problem. When I try to log in the screen goes blank for a couple seconds, and then it drops back to the kdm login screen again.

The only suspicious information I can find in the Xorg log (with no xorg.conf) is:


(WW) RADEON(0): Direct rendering disabled
(EE) RADEON(0): Acceleration initialization failed

and


(EE) Logitech USB Optical Mouse: Read error: No such device

The mouse works fine, however. I'm really in a tough spot here, I'm relying on this computer for some upcoming work. Could anyone offer a suggestion?

rdieter
26th February 2009, 07:45 PM
> Feb 25 09:50:44 Updated: xorg-x11-server-Xorg-1.5.3-13.fc10.i386

Would be the most likely culprit

liedekef
26th February 2009, 08:15 PM
Thought so to ... somehow the login screen uses qwerty by default again, even though in my case "be-latin1" is displayed, so I expect azerty. You can fix it by selecting and clicking your username, and then (before entering your password) at the bottom, add and select the correct keyboard layout again.
Even after login in, the gnome session has US keyboard layout and I need to reset it to the correct layout again.

Franky

paladin_zero
26th February 2009, 09:57 PM
> Feb 25 09:50:44 Updated: xorg-x11-server-Xorg-1.5.3-13.fc10.i386

Would be the most likely culprit

I just tried downgrading to Xorg-1.5.3-5.fc10.i386, but after rebooting I still cant log in. I also tried installing gnome-desktop, and I can't log in there either, I get a warning:



There is a problem with the configuration server
(/usr/libexec/gconf-sanity-check-2 exited with a status of 256)

and when I close that dialog I have to ctrl-alt-bksp to get back to the login screen.

paladin_zero
27th February 2009, 09:26 PM
It turns out the problem was not related to the yum update, which turned out to be an unfortunately timed coincidence. I had run out of space in my /tmp directory, and I guess /tmp is not cleared during a reboot. When I removed the offending large file (and expanded the partition for good measure), I was able to log in again.

Sorry for the noise.

Hlingler
27th February 2009, 10:35 PM
You do have package tmpwatch installed and working correctly, right? You can move the CRON file from /etc/cron.daily/ to /etc/cron.hourly/ and/or make other tweaks (in addition to what you did: expand /tmp/ partition). Read: man tmpwatch.

V