View Full Version : FC2 & PCMCIA Wireless card

19th May 2004, 09:48 PM
I orginally posted this in the networking forum here (http://www.fedoraforum.org/forum/showthread.php?s=&threadid=2066):

I just did a clean install of FC2 and I am having a problem getting my Lucent WaveLan Silver card working on my laptop (Compaq Evo n160). During boot I get the following in /var/log/messages:
localhost network: Bringing up interface eth1: failed
localhost ifup: orinoco_cs device eth1 does not seem to be present, delaying initialization.
localhost ifup: interface 'eth1' not found
localhost network: Bring up interface eth1: failed

Now, I tried restarting networking after boot and get the same messages. I tried restarting pcmcia and I get:
Shutting down PCMCIA service: done.
Starting PCMCIA services: cardmgr[2839]: no sockets found!

I assume PCMCIA is the problem, but anyone have any suggestions? This worked out of the box on FC1 so I didn't run into any of these issues.

19th May 2004, 09:51 PM
In the other thread, yesterday had this comment:

Originally posted by Yestrday
I am having the same problem and I believe it is a consequence of the kernel and some driver differences with 2.4.

The installer detected an orinoco_cs run card in my machine (Toshiba 5105-S701) which returns the same error to me as you got.:(

I hope this has an easy fix, I would really like to upgrade to FC2.

20th May 2004, 02:46 AM
I am also having this same problem on a fresh install of FC2 today. I hope someone has a solution.


20th May 2004, 03:15 AM
I am having the same problem - so far what I've figured out is that in /etc/init.d/pcmcia, there's a line that greps /proc/devices for the string 'pcmcia', and if it's not found it modprobes the yenta_socket.

On FC1 apparently this line isn't there on boot, but in FC2 it is; so the grep fails and the modprobe never happens. Probably a 2.4 -> 2.6 ACPI thing, who knows.

I'm going to hack that to do something like "lsmod | grep yenta_socket" or similar to get around the problem. More proper solutions welcome.

20th May 2004, 03:41 AM
Let us know if that definately solves the problem. I left my laptop at work so I can't try it out till tommorrow.

20th May 2004, 03:46 AM
It seems to so far if you jiggle the subsytem a little; I replaced the line:

if ! grep -q pcmcia /proc/devices


if ! /sbin/lsmod | grep -q $PCIC

That at least loads the yenta_socket and all that jazz. The rest of it I'm not sure what was wrong (I have an internal eth0, and an orinoco pccard on eth1) but after a few pcmcia stop/starts and pulling the card out and in, it finally was recognized and came online.

It's working now, apt-getting the latest updates. Not sure how it's going to react on boot, may take a few tweaks - whatever the cause, it sure seems like pcmcia is broken.

20th May 2004, 02:47 PM
Well I was also able to get rivvah's hack to work. but it doesnt work on boot and it doesnt work with a pcmcia restart. but if i stop it, then start it. the card fires up.

Seems kinda slow though, like maybe its not loading up all that it should be. But at least I can read the forums from the couch! =)

20th May 2004, 07:36 PM
Yah I found the same thing -- here's my final hackery so far:

1) replace that line in init.d/pcmcia
2) set ONBOOT=no for eth1 (wireless)
3) after system is booted, run '/etc/init.d/pcmcia restart'

This has at least worked consistently for me, so the last thing to figure out is why it doesn't work initially on boot. Perhaps moving the pcmcia initalization after some other script...?

21st May 2004, 02:27 PM

22nd May 2004, 04:28 AM
this will get you running once u are set logged in

@ terminal enter as root

/sbin/modprobe yenta_socket
/etc/init.d/pcmcia restart

22nd May 2004, 02:31 PM
ignore this message. It is working now.

2nd June 2004, 12:17 AM
Why does it work now? What was the final fix? I have this exact same problem on my system :(


2nd June 2004, 07:00 AM
Originally posted by imnes
Why does it work now? What was the final fix? I have this exact same problem on my system :(

Exactly what rivvah posted earlier in the thread worked for me.

15th June 2004, 05:21 PM
In the /etc/modprobe.conf file I put a # in front of the line "alias eth1 orinoco_cs" so it looked like this.

#alias eth1 orinoco_cs

Now it starts automatically and I do not have to do the modprobe yenta_socket. Found this in bugzilla.


16th June 2004, 05:29 AM
The newest kernel also fixes the problem of having to run /etc/init.d/pcmcia restart; I just upgraded to 2.6.6-1.435 (without touching anything else) and it now fires up on boot with the previous fixes in place.

(my alias eth1 line is NOT commented out)


5th July 2004, 10:41 PM
Hi, all

I have follow your differents suggest and I have found procedure to resolve this problem :)

sockets detection

a) edite the file /etc/init.d/pcmcia

b) comment this line with #

if ! grep -q pcmcia /proc/devices ; then

c) and replace it with that line

if ! /sbin/lsmod | grep -q $PCIC ; then

d) save the file ( txs rivvah for this tips )

Detection pcmcia controler before networking service

a) make cd /etc/rc3.d

b) create a symblolic link with "/etc/init.d/pcmcia" befor the network

ln -s /etc/init.d/pcmcia /etc/rc3.d/S09pcmcia

c) reboot the system.

and that work fine ;) , in any case in my hold laptop, that 's ok