PDA

View Full Version : Yum not finding mirror(s)



bandicoot
22nd January 2009, 07:02 AM
Is anyone else having trouble with the mirrors http://ga13.files.bigpond.com:4040/fedora/linux and http://ga14.files.bigpond.com:4040/fedora/linux (the main mirrors for Australia)? I tried to download FC10 about a week ago, without success.

After I got FC10 from another mirror, I tried to use Yum, but it defaults to the two URLs named above.. System Update works fine though. I suppose someone should be told about the outage, but I don't know who. Any ideas?

Also, why does Yum use only two mirrors for Yum (especially at the same provider)? Is there any security reason why I should not use another mirror? If it is okay to use another mirror(?), how would I do that in terminal?

Thanks in advance.

martin-tack
22nd January 2009, 07:58 AM
Hi bandicoot

There is no security reason ,so you can use others.

Can you post the text inside the file's '/etc/yum.repos.d/fedora.repo' And '/etc/yum.repos.d/fedora-updates.repo'

To do so ,open a terminal and :

"su -c ' gedit /etc/yum.repos.d/fedora.repo' " (without double quote's ,what's between them)
enter your root pasw.

In the tekst editor select the whole text and copy & paste it in the new post to this tread .

The same for fedora-updates.repo

That will give me an idea how yum is installed / configured in Australia , and find a solution.

Besides a possible problem with mirror URL's , its also depending on what plugins for yum
are installed on your system ,as I writhe I'm thinking on a way to find that out on a distance .

martin-tack

Gent

Belgium ( Flanders)

marcrblevins
22nd January 2009, 11:20 PM
What does 'yum repolist' say?

sideways
22nd January 2009, 11:30 PM
You can force yum to change mirror during a download by pressing ctrl-c once (pressing twice exits), if the new mirror is still slow wait a couple of seconds and press ctrl-c again, it should have a large number of mirrors to try.

bandicoot
23rd January 2009, 03:57 AM
Thanks for your advice/hints -- I now have Yum working, and learnt a couple of things in the process.
Best wishes,
Bandicoot.

ozjd
23rd January 2009, 04:27 AM
I have been having similar problems with the mirrors in Australia. They are all slow at the moment. It took a couple of hours to install xfce (60 meg). Kept changing mirrors, my yumex window was all red due to the mirror timeouts. Thought it was my internet but it is ok for normal use.