PDA

View Full Version : problems with make



Mr tim esquire
21st January 2009, 12:32 PM
I've run the configure file and there's defiantly a makefile in the dir. However when I run make, as user and as root I get a 'make: command not found error'. There is a man entry for make, but make --version returns 'make: command not found'.

I'm running FC10 with gcc installed
Has make been superseded?
If so whats the alternitive ?

thanks
Tim

doncot
21st January 2009, 12:49 PM
[QUOTE=Mr tim esquire;1152764]I've run the configure file and there's defiantly a makefile in the dir. However when I run make, as user and as root I get a 'make: command not found error'. There is a man entry for make, but make --version returns 'make: command not found'.

I'm running FC10 with gcc installed
Has make been superseded?
If so whats the alternitive ?

thanks
Tim[/QUOTE

Hi Tim,

Why not show your passing processor.Even root or user ? That's the data can be thinking and help you.

Mr tim esquire
21st January 2009, 01:18 PM
[root@localhost src]# make
-bash: make: command not found
[root@localhost src]# ls
config.cache g_bang.c makefile.in s_path.c
config.log g_canvas.c makefile.irix s_portaudio.c
config.status g_canvas.h makefile.nt s_print.c
configure g_editor.c makefile.nt.bad s_sgi.c
configure.in g_graph.c m_atom.c s_unix.c
CVS g_guiconnect.c m_binbuf.c s_watchdog.c
d_arithmetic.c g_hdial.c m_class.c t_main.c
d_array.c g_hslider.c m_conf.c t_tkcmd.c
d_ctl.c g_io.c m_glob.c t_tk.h
d_dac.c g_mycanvas.c m_imp.h u_main.tk
d_delay.c g_numbox.c m_memory.c u_main.tk.test
d_fft.c g_readwrite.c m_obj.c u_pdreceive.c
d_fftroutine.c g_rtext.c m_pd.c u_pdsend.c
d_filter.c g_scalar.c m_pd.h x_acoustics.c
d_global.c g_template.c m_sched.c x_arithmetic.c
d_math.c g_text.c notes.txt x_connective.c
d_mayer_fft.c g_toggle.c s_entry.c x_gui.c
d_misc.c g_traversal.c s_file.c x_interface.c
d_osc.c g_vdial.c s_freebsd.c x_midi.c
d_resample.c g_vslider.c s_inter.c x_misc.c
d_soundfile.c g_vumeter.c s_linux.c x_net.c
d_ugen.c install-sh s_loader.c x_qlist.c
g_all_guis.c makefile s_mac.c x_time.c
g_all_guis.h makefile.clean s_main.c
g_array.c makefile.dependencies s_nt.c
[root@localhost src]# make -version
-bash: make: command not found

Hlingler
21st January 2009, 01:21 PM
Check:
[Vince@localhost Tue Jan 20 19:08:54 ~]$ rpm -q make
make-3.81-11.fc8.i386
[Vince@localhost Wed Jan 21 07:20:04 ~]$V

P.S. Check #2, verify package integrity (blank output=no altered files):
[Vince@localhost Wed Jan 21 07:20:04 ~]$ rpm -V make
[Vince@localhost Wed Jan 21 07:22:17 ~]$Check #3, verify command PATH:
[Vince@localhost Wed Jan 21 07:22:17 ~]$ echo $PATH
/usr/java/default/bin:/usr/kerberos/bin:/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin:/home/Vince/bin
[Vince@localhost Wed Jan 21 07:23:18 ~]$Post results.

doncot
21st January 2009, 01:41 PM
[root@localhost src]# make
-bash: make: command not found
[root@localhost src]# ls
config.cache g_bang.c makefile.in s_path.c
config.log g_canvas.c makefile.irix s_portaudio.c
config.status g_canvas.h makefile.nt s_print.c
configure g_editor.c makefile.nt.bad s_sgi.c
configure.in g_graph.c m_atom.c s_unix.c
CVS g_guiconnect.c m_binbuf.c s_watchdog.c
d_arithmetic.c g_hdial.c m_class.c t_main.c
d_array.c g_hslider.c m_conf.c t_tkcmd.c
d_ctl.c g_io.c m_glob.c t_tk.h
d_dac.c g_mycanvas.c m_imp.h u_main.tk
d_delay.c g_numbox.c m_memory.c u_main.tk.test
d_fft.c g_readwrite.c m_obj.c u_pdreceive.c
d_fftroutine.c g_rtext.c m_pd.c u_pdsend.c
d_filter.c g_scalar.c m_pd.h x_acoustics.c
d_global.c g_template.c m_sched.c x_arithmetic.c
d_math.c g_text.c notes.txt x_connective.c
d_mayer_fft.c g_toggle.c s_entry.c x_gui.c
d_misc.c g_traversal.c s_file.c x_interface.c
d_osc.c g_vdial.c s_freebsd.c x_midi.c
d_resample.c g_vslider.c s_inter.c x_misc.c
d_soundfile.c g_vumeter.c s_linux.c x_net.c
d_ugen.c install-sh s_loader.c x_qlist.c
g_all_guis.c makefile s_mac.c x_time.c
g_all_guis.h makefile.clean s_main.c
g_array.c makefile.dependencies s_nt.c
[root@localhost src]# make -version
-bash: make: command not found


What are you making by root ?

Mr tim esquire
21st January 2009, 02:13 PM
ahem, sorry guys didnt have make installed.
I was just trying root as i couldn't get make to work with my normal user, unsuprisingly.
Thanks!

Hlingler
21st January 2009, 03:25 PM
To avoid most further compile problems:
yum groupinstall "Development Tools" "Development Libraries"

V