PDA

View Full Version : mount: error mounting /dev/root on /sysroot as ext3: No such file or directory



Taniel
21st January 2009, 06:20 AM
Hi

I'm using Etherboot to load a network boot image I created using wraplinux(1.6-1) on F10.
When the PC is executing the NBI it downloads through TFTP off the server, the kernel starts to load and eventually stops with the message
"mount: error mounting /dev/root on /sysroot as ext3: No such file or directory"

I believe this problem is occuring in the initrd part of the NBI.
the wraplinux command I have been using is

wraplinux -E -p "root=/dev/nfs nfsroot=/raid/nfsroot.ios" -i initrd-2.6.27.5-117.fc10.i686.img -o kernel.ios vmlinuz-2.6.27.5-117.fc10.i686

I'm trying to get the kernel to mount the folder /raid/nfsroot.ios on the server, but it appears the kernel paramaters I have put in have been ignored or not reached.

Judging by other posts I have seen with this error, the error is overcome by running mkinitrd with the option --with=scsi_wait_scan. I have tried this and it hasn't worked.
The only drive I have that may fall under that category is a sata cdrom.

I used FC10 on the client to produce the the NBI
I'm trying to load a second stage boot loader off the server. The server is also running FC10.

Does anyone have any idea or suggestions as to why this case is different? I haven't found anyone else trying to do the same thing with FC10.

Orioner
21st January 2009, 09:34 AM
I have a similar problem. Booting Fed 10 problem begins with video crash, then on rebooting:---
"Activating logical volumes
"creating root filesystem"
"Mounting root filesystem"
Then: "Mount: error mounting /dev/root on /sysroot as ext3: Device or resource busy"

Tried rescue but damned Fed10 disc can't find boot, so tried Fed 9 disc rescue mode - no luck and no idea how to proceed now. Help appreciated. Fed10 has been running with no problems until now.

Taniel
23rd January 2009, 12:56 AM
I think I narrowed my problem down to the /etc/fstab causing the problem. I want it to load the servers /raid/nfsroot.ios nfs but its trying to mount the partitions on the local HDD. Does anyone know how to set the fstab such that it looks on the server instead of the local drive? The problem with fstab is that it requires a local mount point, and I'm trying to use this as a hard disk image rollout method, so there is not going to be a local mount point available, as the hard disk will be blank.

Help this problem is driving me crazy?

Orioner
23rd January 2009, 08:54 PM
I hope someone helps you, Taniel, and I hope someone tells me how to fix my problem too. What device or resource busy is the system telling me is the problem and how do I fix it, please.

Buffer i/o error on device DM-3 - this appeared prior to the details I quoted in my earlier post Jan 21st. If this is the origin of my problem, please advise how to correct it - tnx, anyone!!

qonthoz
7th May 2009, 08:52 AM
I'm having same problem with taniel, where the sound of fedora developer ?
Would you please give us an advise.

Loki1950
7th May 2009, 08:59 AM
@qonthoz no developers on this forum we are all just users some a bit more knowledgeable but still users.

Enjoy the Choice :)