PDA

View Full Version : Cell phone can't downloads photos



vinoman
21st January 2009, 01:26 AM
I have a Sony Ericsson TM 506 cellphone. Fedora 10 won't recognize it when I plug it in. I select the mass storage option that works in Windows.

How do I get it to work in Fedora 10 64bit?

John the train
21st January 2009, 10:39 AM
Bit of a workaround, but I've been having difficulty sourcing a data cable for my LG KG130, so I'm D/Ling my photos by sending them to my e-mail in-box as a multi-media message. Take a look at your address book, if there's a space for e-mail address your phone should have this facility - most camera phones do. Hope this is of some use.

vinoman
21st January 2009, 01:18 PM
So there is no way for Fedora to recognize the cellphone via mu usb plug?

There is a charge everytime you sending photos to emails.

Why can't Fedora see the cellphone as another hard drive? Like a digital camera?

trigpoint
21st January 2009, 01:33 PM
Strange, my wife once had a Sony Ericson phone, and it worked fine as a USB mass storage device. Can you post the output of dmesg after you plug the phone in?

vinoman
21st January 2009, 01:49 PM
Strange, my wife once had a Sony Ericson phone, and it worked fine as a USB mass storage device. Can you post the output of dmesg after you plug the phone in?

it's very long... here's the bottom part that shows that it sees the Sony-Ericsson

SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
npviewer.bin[3982]: segfault at ff9d0aa0 ip 00000000ff9d0aa0 sp 00000000fff84fcc error 14
usb 2-7: new full speed USB device using ohci_hcd and address 5
usb 2-7: configuration #2 chosen from 1 choice
usb 2-7: New USB device found, idVendor=0fce, idProduct=e0d6
usb 2-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-7: Product: Memory Stick
usb 2-7: Manufacturer: Sony Ericsson
usb 2-7: SerialNumber: 3550760221708080
Initializing USB Mass Storage driver...
scsi4 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
[davek@davek ~]$

vinoman
21st January 2009, 01:54 PM
I just tried the media transfer option instead of mass storage and it worked!

Problem solved!