PDA

View Full Version : KDE: Nvidia and Desktop effects



TechDragon
20th January 2009, 03:14 AM
Fedora 10
All updates to factory
KDE desktop 4.1..
Nvidia Video

When I enable desktop effects the screen goes black and will not return to a usable desktop.

any ideas?

Lindy
20th January 2009, 03:24 AM
Do you have the the third party Nvidia drivers installed? is this the KDE effects or Compiz? If it's the KDE effects you'll need to enable compositing.
From my xorg.conf:

Section "Extensions"
Option "Composite" "Enable"
As far as I know you'll need compositing for Compiz as well...
BTW you're not giving anybody much to go on here, some specs would be nice:) Nvidia Video? What version? Throw a dog a bone and you'll get a better response. Well at least better than my prattling...

TechDragon
20th January 2009, 04:55 PM
If I wasnt such a noob I could give u more to go on. lol

I tried it with the nivida beta drivers first and had the black screen o death. I couldn't get it fixed, and has to re-install the system.

I then tried the stable drivers and had the same thing happen

the laptop is a T61 with an Nvidia Quadro in it. Everything seems to work except the special effects.

Lindy
22nd January 2009, 08:42 AM
The best way to go with 3rd party video drivers is to get them from the RPM Fusion (http://rpmfusion.org/RPM%20Fusion) repo's then use yum to install them. More info on installing RPM Fusion can be had here (http://rpmfusion.org/Configuration).
Post your xorg.conf file (/etc/X11/xorg.conf) and we'll see if anything needs tweaking.