PDA

View Full Version : System update problem



usefule_idiot
18th January 2009, 09:02 PM
Hi All,

I'm getting this strange error since I installed FC10.
I can't update the system if I install RPM fusion repositories, and if I don't I can't get some very basic packages. :)

1. I don't have any rawhide repo enabled

[root@localhost ~]# yum repolist
Loaded plugins: refresh-packagekit
repo id repo name status
fedora Fedora 10 - i386 enabled: 11,416
rpmfusion-free RPM Fusion for Fedora 10 - Free enabled: 404
rpmfusion-free-updates RPM Fusion for Fedora 10 - Free - Updates enabled: 256
rpmfusion-nonfree RPM Fusion for Fedora 10 - Nonfree enabled: 200
rpmfusion-nonfree-updates RPM Fusion for Fedora 10 - Nonfree - Updates enabled: 143
updates Fedora 10 - i386 - Updates enabled: 2,694
repolist: 15,113
[root@localhost ~]#

2. Don't have any fc11 rawhide package installed

[root@localhost ~]# rpm -qa | grep fc11
[root@localhost ~]#

which means I never enabled rawhide repo.

3. yum udpate --

[root@localhost ~]# yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package abiword.i386 1:2.6.6-1.fc10 set to be updated
---> Package hal-libs.i386 0:0.5.12-14.20081027git.fc10 set to be updated
...
---> Package libsilc.i386 0:1.1.8-1.fc10 set to be updated
---> Package hal.i386 0:0.5.12-14.20081027git.fc10 set to be updated
---> Package file-libs.i386 0:4.26-4.fc10 set to be updated
---> Package rpmfusion-nonfree-release.noarch 0:10.90-1 set to be updated
--> Processing Dependency: system-release >= 10.90 for package: rpmfusion-nonfree-release
---> Package file.i386 0:4.26-4.fc10 set to be updated
---> Package totem-pl-parser.i386 0:2.24.3-1.fc10 set to be updated
---> Package hal-info.noarch 0:20081219-1.fc10 set to be updated
--> Running transaction check
---> Package aalib-libs.i386 0:1.4.0-0.16.rc5.fc10 set to be updated
--> Processing Dependency: libgpm.so.2 for package: aalib-libs
---> Package libmusicbrainz3.i386 0:3.0.2-1.fc10 set to be updated
--> Processing Dependency: libdiscid.so.0 for package: libmusicbrainz3
---> Package rpmfusion-free-release.noarch 0:10.90-1 set to be updated
--> Processing Dependency: system-release >= 10.90 for package: rpmfusion-free-release
---> Package rpmfusion-nonfree-release.noarch 0:10.90-1 set to be updated
--> Processing Dependency: system-release >= 10.90 for package: rpmfusion-nonfree-release
--> Running transaction check
---> Package libdiscid.i386 0:0.2.2-1.fc10 set to be updated
---> Package rpmfusion-free-release.noarch 0:10.90-1 set to be updated
--> Processing Dependency: system-release >= 10.90 for package: rpmfusion-free-release
---> Package gpm.i386 0:1.20.5-2.fc10 set to be updated
---> Package rpmfusion-nonfree-release.noarch 0:10.90-1 set to be updated
--> Processing Dependency: system-release >= 10.90 for package: rpmfusion-nonfree-release
--> Finished Dependency Resolution
rpmfusion-nonfree-release-10.90-1.noarch from rpmfusion-nonfree has depsolving problems
--> Missing Dependency: system-release >= 10.90 is needed by package rpmfusion-nonfree-release-10.90-1.noarch (rpmfusion-nonfree)
rpmfusion-free-release-10.90-1.noarch from rpmfusion-free has depsolving problems
--> Missing Dependency: system-release >= 10.90 is needed by package rpmfusion-free-release-10.90-1.noarch (rpmfusion-free)
Error: Missing Dependency: system-release >= 10.90 is needed by package rpmfusion-nonfree-release-10.90-1.noarch (rpmfusion-nonfree)
Error: Missing Dependency: system-release >= 10.90 is needed by package rpmfusion-free-release-10.90-1.noarch (rpmfusion-free)
[root@localhost ~]#

4. yum install vlc

[root@localhost ~]# yum install vlc
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package vlc.i386 0:0.9.8a-1.fc11 set to be updated
--> Processing Dependency: vlc-core = 0.9.8a-1.fc11 for package: vlc
--> Processing Dependency: libcvaux.so.1 for package: vlc
...
--> Processing Dependency: libavcodec.so.52 for package: vlc-core
--> Processing Dependency: libdvdnav.so.4 for package: vlc-core
--> Processing Dependency: libebml.so.0 for package: vlc-core
--> Processing Dependency: libgroupsock.so.0 for package: vlc-core
---> Package fluidsynth-libs.i386 0:1.0.8-2.fc10 set to be updated
--> Processing Dependency: liblash.so.1 for package: fluidsynth-libs
--> Processing Dependency: lash for package: fluidsynth-libs
---> Package aalib-libs.i386 0:1.4.0-0.16.rc5.fc10 set to be updated
--> Processing Dependency: libgpm.so.2 for package: aalib-libs
---> Package qt.i386 1:4.4.3-10.fc10 set to be updated
---> Package qt-x11.i386 1:4.4.3-10.fc10 set to be updated
--> Running transaction check
---> Package libmpcdec.i386 0:1.2.6-4.fc9 set to be updated
---> Package live555.i386 0:0-0.20.2008.07.25.fc10 set to be updated
---> Package faad2-libs.i386 1:2.6.1-6.fc10 set to be updated
---> Package freeglut.i386 0:2.4.0-14.fc9 set to be updated
---> Package portaudio.i386 0:19-6.fc10 set to be updated
---> Package libmatroska.i386 0:0.8.1-3.fc9 set to be updated
---> Package jack-audio-connection-kit.i386 0:0.116.1-3.fc10 set to be updated
--> Processing Dependency: libfreebob.so.0 for package: jack-audio-connection-kit
---> Package libdvbpsi.i386 0:0.1.6-3.fc10 set to be updated
---> Package vlc.i386 0:0.9.8a-1.fc11 set to be updated
--> Processing Dependency: dejavu-fonts-sans for package: vlc
---> Package x264-libs.i386 0:0.0.0-0.22.20081213git9089d21.fc11 set to be updated
--> Processing Dependency: libgpac.so.0 for package: x264-libs
---> Package libsysfs.i386 0:2.1.0-4.fc10 set to be updated
---> Package twolame-libs.i386 0:0.3.12-3.fc10 set to be updated
---> Package lirc-libs.i386 0:0.8.4a-1.fc10 set to be updated
---> Package gpm.i386 0:1.20.5-2.fc10 set to be updated
---> Package libmodplug.i386 1:0.8.4-3.fc9 set to be updated
---> Package ffmpeg-libs.i386 0:0.4.9-0.57.20081217.fc11 set to be updated
--> Processing Dependency: libgsm.so.1 for package: ffmpeg-libs
--> Processing Dependency: libdc1394.so.22 for package: ffmpeg-libs
--> Processing Dependency: libImlib2.so.1 for package: ffmpeg-libs
--> Processing Dependency: libxvidcore.so.4 for package: ffmpeg-libs
--> Processing Dependency: libfaac.so.0 for package: ffmpeg-libs
---> Package libupnp.i386 0:1.6.6-1.fc10 set to be updated
---> Package libebml.i386 0:0.7.8-1.fc9 set to be updated
---> Package libdca.i386 0:0.0.5-3.fc10 set to be updated
---> Package lash.i386 0:0.5.4-2.fc9 set to be updated
---> Package SDL_image.i386 0:1.2.6-6.fc9 set to be updated
---> Package zvbi.i386 0:0.2.30-1.fc9 set to be updated
---> Package schroedinger.i386 0:1.0.5-3.fc10 set to be updated
---> Package xorg-x11-fonts-misc.noarch 0:7.2-6.fc9 set to be updated
---> Package libdvdnav.i386 0:4.1.3-1.fc10 set to be updated
---> Package libcddb.i386 0:1.3.0-4.fc9 set to be updated
--> Running transaction check
---> Package libfreebob.i386 0:1.0.11-3.fc10 set to be updated
---> Package libdc1394.i386 0:2.0.2-1.fc10 set to be updated
---> Package faac.i386 0:1.26-1.fc11 set to be updated
--> Processing Dependency: libmp4v2.so.0 for package: faac
---> Package vlc.i386 0:0.9.8a-1.fc11 set to be updated
--> Processing Dependency: dejavu-fonts-sans for package: vlc
---> Package gsm.i386 0:1.0.12-6.fc9 set to be updated
---> Package gpac-libs.i386 0:0.4.5-2.fc11 set to be updated
--> Processing Dependency: libopenjpeg.so.2 for package: gpac-libs
---> Package xvidcore.i386 0:1.2.1-1.fc11 set to be updated
---> Package imlib2.i386 0:1.4.2-2.fc10 set to be updated
--> Processing Dependency: libgif.so.4 for package: imlib2
--> Running transaction check
---> Package vlc.i386 0:0.9.8a-1.fc11 set to be updated
--> Processing Dependency: dejavu-fonts-sans for package: vlc
---> Package giflib.i386 0:4.1.3-9 set to be updated
---> Package openjpeg-libs.i386 0:1.3-2.fc9 set to be updated
---> Package libmp4v2.i386 0:1.5.0.1-6.fc10 set to be updated
--> Finished Dependency Resolution
vlc-0.9.8a-1.fc11.i386 from rpmfusion-free has depsolving problems
--> Missing Dependency: dejavu-fonts-sans is needed by package vlc-0.9.8a-1.fc11.i386 (rpmfusion-free)
Error: Missing Dependency: dejavu-fonts-sans is needed by package vlc-0.9.8a-1.fc11.i386 (rpmfusion-free)
[root@localhost ~]#

why is it looking for fc11 package?

Would really appreciate any help..
Thanks.

Nokia
18th January 2009, 10:05 PM
Try
wget http://ftp-stud.hs-esslingen.de/pub/Mirrors/rpmfusion.org/free/fedora/releases/10/Everything/i386/os//rpmfusion-free-release-10-1.noarch.rpm http://ftp-stud.hs-esslingen.de/pub/Mirrors/rpmfusion.org/nonfree/fedora/releases/10/Everything/i386/os//rpmfusion-nonfree-release-10-1.noarch.rpm
su
rpm -Uvh --replacepkgs --replacefiles rpmfusion*rpm
yum clean all
yum update --enablerepo=updates-testing

JohnVV
18th January 2009, 10:55 PM
replacing rpmfusion repo , as above, will do it

Processing Dependency: system-release >= 10.90 for package: rpmfusion-nonfree-release
you have the fedora 11 repo installed

usefule_idiot
19th January 2009, 07:31 PM
@Nokia, Thanks! It surely worked, everything is back to normal! :)

@JohnVV, Yeah, I'm realizing it now. But while installing, I'd strictly followed the instructions as mentioned at this page (http://rpmfusion.org/Configuration/) to configure it for Fedoa 8, 9, 10. :-/