PDA

View Full Version : Fedora 10 GRUB showing black screen with text



otnateos
4th January 2009, 08:09 AM
Hi,

I'm having problem with my Fedora 10's GRUB (i think most likely GRUB problem). After GRUB is loaded it will show a black screen with some dodgy blue text showing it is booting specific kernel. However it will show the normal nice GRUB boot selector after I press anything on the keyboard.

Initially I encounter problem which GRUB won't load at all, it's showing text

GRUB
and then doing nothing at all. So I loaded up the installation disk and run

grub-install --recheck /dev/sda
then the next time I reboot my boot screen showing the black screen before loading the actual boot selector.

Has anyone encounter the same issue ? or should I change the splash file ?

SlowJet
4th January 2009, 01:50 PM
Grub fails to install on some computers - you manually installed grub so that is one problem solved.
The other black screen and a delay is the loading of the kernel and starting up of Plymouth.
You should get a blue and white text line pulsing on the bottom after about 12 seconds.

To change that to the exploding star enter on the grub kernel line
vga=0x315


SJ

scottro
4th January 2009, 03:10 PM
Sometimes 0x=318 works better. I think that 0x315 is for netboooks, though I might have that backwards. :)
That's the numeral zero, not an upper case o.

otnateos
5th January 2009, 01:12 PM
Grub fails to install on some computers - you manually installed grub so that is one problem solved.
SJ

hmn.. yes grub problem is solved, but the main thing that I don't really like is the screen prior the loading with the progress at the bottom where it is showing it is going to boot the specific kernel in few seconds.

as i remember before i got that GRUB issue, I tried to install fglrx driver.



The other black screen and a delay is the loading of the kernel and starting up of Plymouth.
You should get a blue and white text line pulsing on the bottom after about 12 seconds.

To change that to the exploding star enter on the grub kernel line
vga=0x315
SJ

I was planning to start up Plymouth as well, thanks for pointing me to the right directions, however I set it up using

vga=0x346
i think the resolution is 1400x1050

1weak1
5th January 2009, 01:34 PM
I have that ugly grub too, dont know why.

premudriy
11th January 2009, 02:38 AM
Edit your /boot/grub/grub.conf file and comment out line "hidemenu" with "#" symbol in front of that line. Then your screen will show a blue solar grub splash.


P.S.: I don't know how come with "hidemenu" left ON there's some blue colors "leak" in.