PDA

View Full Version : FC10 - inittab quirk, just solved but for info



markdk
4th January 2009, 01:57 AM
This is a complete reverse of all the posts I've seen to do with X-windows, most of those were on how to start it; I wanted to stop it :-).

I've just upgraded a server from FC6 to FC10 (well OK, fresh-installed to FC10 upgrade just wasn't possible). I had not been able to figure out to get it to boot in runlevel 3.

On FC6 and FC8 getting rid of the X-windows stuff and sticking with a nice command prompt was a simple case of changing the initdefault in the /etc/inittab file from runlevel 5 to runlevel 3, that doesn't work in FC10.

My inittab is below; even though the default is set to 3 still all the X-windows services start.

[mark@falcon ~]$ cat /etc/inittab
# inittab is only used by upstart for the default runlevel.
#
# ADDING OTHER CONFIGURATION HERE WILL HAVE NO EFFECT ON YOUR SYSTEM.
#
# System initialization is started by /etc/event.d/rcS
#
# Individual runlevels are started by /etc/event.d/rc[0-6]
#
# Ctrl-Alt-Delete is handled by /etc/event.d/control-alt-delete
#
# Terminal gettys (tty[1-6]) are handled by /etc/event.d/tty[1-6] and
# /etc/event.d/serial
#
# For information on how to write upstart event handlers, or how
# upstart works, see init(8), initctl(8), and events(5).
#
# Default runlevel. The runlevels used are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
#id:5:initdefault:
id:3:initdefault:
[mark@falcon ~]$

It still starts in runlevel 5.
[mark@falcon ~]$ runlevel
N 5

...

SOLVED
But as I was typing this post I thought, what if I removed the line I had commented out. Did that and rebooted. Well darn, that worked.

So this post was going to be a how to I get in into runlevel 3,
now its a if anyone else has issues changing default boot runlevels on bootup, it takes the first initdefault entry even if it is commented out.

Don't know if this is new or not as on checking my old fc6 config the commented line was below the working initdefault.

sideways
4th January 2009, 02:05 AM
it's a bug in the Upstart script /etc/event.d/rcS, fc6 didn't use Upstart (it was introduced in F7 iirc)

It has been fixed (so commented lines are now correctly ignored) in upstream code but not released into a new fedora package yet, should be there soon