PDA

View Full Version : DPMS not working in F10?



sej7278
2nd January 2009, 10:56 PM
64-Bit Fedora 10, nvidia driver from livna, lcd display with dvi input.

gnome-screensaver set to activate when idle, idle after 5mins, lock screen.

gnome-power-manager set to put display to sleep after 10mins.

it only works when i set the option in gnome-power-manager - it doesn't survive a reboot, i.e. if i run g-p-m, then click close, the dpms works after 10mins, but it doesn't next time i login.

the screensaver always works fine, but it doesn't put my lcd into powersaving mode.

/var/log/Xorg.0.log has:



(II) Loading extension DPMS
(II) NVIDIA(0): DPMS enabled


"xset q" reports:



DPMS (Energy Star):
Standby: 0 Suspend: 0 Off: 0
DPMS is Enabled
Monitor is On


"xset dpms 10 20 30" works, as does "sleep 1 ; xset dpms force off"

i can't see it being a problem with the nvidia drivers or xset, i'd say its a gnome-screensaver bug, although it doesn't work with xscreensaver either.

any ideas?

LinuxTom
3rd January 2009, 01:05 AM
Try adding something like this in /etc/X11/xorg.conf and setting it to the time you need


Section "ServerFlags"
Option "BlankTime" "15"
Option "StandbyTime" "60"
Option "SuspendTime" "0"
Option "OffTime" "0"
EndSection

Section "Monitor"
Option "DPMS" "true"
EndSection

sej7278
3rd January 2009, 09:36 AM
thanks, i tried that and i got some error like "prefdm respawning too fast" when i logged out of x, and had to reboot.

LinuxTom
3rd January 2009, 07:16 PM
Check the xorg.conf for typos, you didn't delete anything did you? That is saying the X configuration is messed up, look at /var/log/Xorg.0.log for lines startting with EE.