PDA

View Full Version : HELP Grub problem after update



tweakedlogic
31st December 2008, 08:52 PM
Yesterday I finally finished my transition from XP to Fedora. Later, I installed some updates with the software updagrade tool. Today, my wife was using it and it prompted her to reboot. Now, I don't have the message that tells me I have three seconds to push any key for kernal options, and it gets stuck when it tries to load GRUB.
I have had issues with this box ever since I upgraded from core 8 to 9.
I have loaded a puppy linux distro to have access to the machine. If it tried harder I might be able to find the directory where the kernal is.
So I have to re-install grub? or is it simpler than that?

stoat
31st December 2008, 09:09 PM
Now, I don't have the message that tells me I have three seconds to push any key for kernal options, and it gets stuck when it tries to load GRUB.Hello tweakedlogic,

It sounds like you are never making it to the GRUB splashscreen and/or menu. That implies that the GRUB stages are busted. And it is not an unheard of thing immediately after a yum update. The usual thing to do for it is re-install the GRUB boot loader.

tweakedlogic
31st December 2008, 09:15 PM
Yes, that is my assessment too. Can I do that while running Puppy Linux?
I tried mounting all the drives in Puppy, it isn't all there, actually, some are there that shouldn't, and one is missing. Puppy is only loaded in RAMdisk, so I guess there is a hidden partition that I didn't know about left over form XP. But I can't see the partitions that should have GRUB and Fedora installed on it. I'll keep at it.

tweakedlogic
1st January 2009, 04:25 AM
Something isn't right.
I cna't see all of the partitions. I have hdd1 which is a hidden 4.3G vfat partition I didn't know about until now. I have hdd2 which is where all my mp3s and movies are. then I have hdc1, it is 196 meg ext3 filesystem, but my master drive (with every thing important) is an 80 gig drive with several partitions. I can't see any of those partitions in puppy linux. This drive is there and powered on, my bios can see it. I can't mount it no matter what I try because it isn't there. I apparently found the swap space.
So I can't re-install grub. I can't find the boot dir. I can't get to my personal files to copy them. I'm Fracked.
Below I pasted from terminal, hdd2 isn't mounted but hdd1 is and not showing up.
Some one help please.

# cd /
# ls
archive dev initrd lost+found proc sbin tmp var
bin etc lib mnt root sys usr
# cd mnt
# ls
cdrive cdrom data flash floppy hdc1 home msdos ram1 swap zip
# cd hdc1
# ls
config-2.6.26.6-49.fc8 System.map-2.6.26.6-49.fc8
config-2.6.27.5-41.fc9.i686 System.map-2.6.27.5-41.fc9.i686
config-2.6.27.9-73.fc9.i686 System.map-2.6.27.9-73.fc9.i686
grub upgrade
initrd-2.6.26.6-49.fc8.img vmlinuz-2.6.26.6-49.fc8
initrd-2.6.27.5-41.fc9.i686.img vmlinuz-2.6.27.5-41.fc9.i686
initrd-2.6.27.9-73.fc9.i686.img vmlinuz-2.6.27.9-73.fc9.i686
lost+found
# pwd
/mnt/hdc1
#

stoat
1st January 2009, 07:01 PM
Well, if Fedora was working before the update, and GRUB is now busted after the update, then it's a commonly observed thing. Nothing should be missing. Just try re-installing the GRUB boot loader for Fedora. But if it were me, I would forget about that Puppy LiveCD and boot with the Fedora DVD (or the 1st CD) and enter linux rescue to do the work by the classic well-known method. But you should do what you want, of course.

TheMadIndian
1st January 2009, 10:17 PM
i use the system rescue cd http://www.sysresccd.org/Main_Page

fdisk -l

"find the one thats noted as boot with the *"

Disk /dev/sda: 20.4 GB, 20416757760 bytes
255 heads, 63 sectors/track, 2482 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000080

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 104391 83 Linux
/dev/sda2 14 2482 19832242+ 8e Linux LVM

"mount that to /boot"

mount /dev/sda1 /boot

"then install grub"

grub-install /dev/sda


reboot and you're all set

tweakedlogic
2nd January 2009, 08:33 AM
I had forgotten all about the rescue CD. Stupid brain. It's late now. I'll try it in the morning.
Thanks. I hate it when I make things harder than they have to be.