PDA

View Full Version : Partial workaround: F10 NXClient + keyboard problems, fuller wanted



dafool
31st December 2008, 07:52 AM
There has been some discussion on the mailing lists (1 (http://www.mailinglistarchive.com/fedora-list@redhat.com/msg155653.htm),2 (https://lists.launchpad.net/freenx-team/msg00134.html)) about situations where keyboard gets wrongly handled on nxclient session where nxclient resides on the "newer" X-implementation + gnome such as Fedora 10.

In my case it meant that Alt Gr mapped to KP_ENTER, left arrow key to Alt Gr, up arrow key to Prnt Scrn and so on.

Easiest partial workaround is to run

setxkbmap -model evdev -layout your_layout on the server side.

This fixes the keyboard for terminals inside the X but for example XChat started from the panel menu still suffers from the broken keyboard. Any ideas how to make this workaround better?

dafool
31st December 2008, 08:02 AM
Answering my own question. To make the solution better is to add the

setxkbmap -model evdev -layout fi
to your .bashrc or similiar on the server side. Logout from the server session and login. The keyboard should work...:)

scottro
6th March 2009, 12:02 AM
Quick thanks for this tip. I couldn't get my arrow keys working during a session till I did this.

mkosunen
14th September 2009, 02:55 PM
The problem seems to be twofold

1) AltGr maps incorrectly
2) Up arrow results in screen snapshot

Solution that worked for me from FC11 client to RHEL 5.3+freenx server is as follows.

1) AltGr maps incorrectly

Solution as suggested
In server sid run "setxkbmap -model evdev -layout fi"

This can be made as default in KDE 3 of RHEL 5.x as follows:
Go to
Control Center-> Regional & Accessibility -> Keyboard Layout
Select "Enable keyboard layouts"
Choose model Generic 105-key (Intl) PC
(This should be "evdev", but it is not available)
Choose correct layout and keymap, for me they are "Finland" and "fi"
Edit the file .kde/share/config/kxkbrc
~> emacs .kde/share/config/kxkbrc
Change line
Model=pc105
to
Model=evdev

Save the file.

Run "setxkbmap -model evdev -layout fi"
for the current session again if required.

2) Up arrow results in screen snapshot
Solution:
In KDE session running in RHEL 5.x server go to
Control Center-> Regional & Accessibility -> Input Actions

From "Preset Actions" select "Print Screen" and disable it

Now the arrow keys should work properly, also in the future NX-sessions.

The problem is also addressed here
http://ubuntuforums.org/archive/index.php/t-959411.html