PDA

View Full Version : network-boot-on



Woodrow Ochs
29th December 2008, 09:01 PM
Evidently I broke something, but I can't now find it to fix it. Could anyone help? In order to enable a dial-up modem I modified my Fedora 10 system with the "system-config-network" GUI, but now I can't get the system to boot up with its eth0 card active even though that option seems to be properly checked in that GUI. Somewhere in the filesystem there is a configuration file which might need to be re-edited, one of those "/xxx/xxx/xxx.conf" files, but I can't remember its name. Also, does anyone know of an ordered and orderly list of such configuration files which would allow someone simply to refer to that list (if such a list exists) in order to find the file he might need to configure or reconfigure in order to resolve a problem somewhat more directly than by hacking away at it for hours - or days - or weeks?

PabloTwo
29th December 2008, 09:28 PM
Try this one:

~/> cat /etc/sysconfig/networking/devices/ifcfg-eth0
# nVidia Corporation CK804 Ethernet Controller
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:15:f2:9b:77:33
ONBOOT=no
DHCP_HOSTNAME=speedie.localdomain
TYPE=Ethernet
USERCTL=yes
PEERDNS=no
IPV6INIT=no
NM_CONTROLLED=no
IPADDR=169.***.**.**
NETMASK=255.255.0.0
GATEWAY=0.0.0.0
Change it to ONBOOT=yes

edit: One thing I've noticed about Network (system-config-network) GUI configuration. Say you have the Modem device highlighted and are on the Device tab, then click on the Hardware tab. The selected device doesn't always remain "sticky", and it will change to, say, the eth0 device as now being highlighted. If you don't catch that switcheroo, then click on the Edit button, thinking your still doing something on the modem, it's possible you unchecked the "activate this device at bootup" box thinking you were doing that for the modem, but actually did that on the eth0 device.

Woodrow Ochs
30th December 2008, 03:19 AM
Pablo, thanks again for your reply, and thanks again for reminding me of the name of that configuration file. I've called it up, and it seems to be in order:# nVidia Corporation CK804 Ethernet Controller
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
USERCTL=yes
PEERDNS=yes
IPV6INIT=no
NM_CONTROLLED=no
TYPE=Ethernet
But the GUI "system-config-network" always resets that "eth0" to "inactive" on every boot-up. Something is causing eth0 to fail to activate on boot-up or to de-activate automatically just after boot-up all the while allowing this configuration file which I have copied (except for the address) to remain just as you now see it. You mentioned that highlighting seems to jump around in the "Network Configuration" GUI, and that is the case with mine: I am wondering about a propensity of mine to associate "eth0" in the "Devices" window with a device "pan0" (rather than "eth0") in the "Hardware" window. Then too there are the 'profiles" which might be in play here, but I can make no sense whatsoever of the gibberish offered as their description in the "Help" section.

PabloTwo
30th December 2008, 03:50 AM
In system-config-network, make sure the big check box on the left hand side under Profile for the eth0 device is checked.

Also check: /etc/sysconfig/network-scripts/ifcfg-eth0
That should pretty much mirror what is in /etc/sysconfig/networking/devices/ifcfg-eth0

And also check in: /etc/sysconfig/networking/profiles/default/ifcfg-eth0 (if it exists)

I think one of those files might be left from when NetworkManager was trying to be the boss on my system, not sure, but they mainly have duplicate, or near duplicate entries.

Woodrow Ochs
30th December 2008, 04:13 AM
Pablo, all of those files check out with "ONBOOT=Yes" etc., but from your posts I must wonder if NetworkManager might not be something like a bad cold which really should be sneezed at. I have Network Manager on my system: Should I remove it?

PabloTwo
30th December 2008, 04:35 AM
I have Network Manager on my system: Should I remove it?
Remove it? No. Turn it off? Maybe. That's really up to you. There are several threads on the forum where you can find various users who have some tiffs with NetworkManager. Myself, I have it turned off in Services, especially since my connection to the outside world from my computer is via dialup, and I don't think NM handles dialup setup and control nearly as well as good 'ol Network (system-config-network).

If NM doesn't cause you any problems, don't worry about it. If it does, shut it off and use strictly Network. Be aware, you cannot have both NM and Network controlling the same device, it has to be one or the other.

I have read some comments from other users here that NM is best suited for laptop users who use their laptops mobile, connecting to different networks as they go. That is NM's strength, as it pries deeply into every nook and cranny to try and discover every possible path to a network connection, and when it finds one, activates it, or at least tries to.

I am a ham radio operator. I have my Linux install configured to to enable the native support of the AX.25 packet ham radio protocol. When I want to use this mode, I have a script that I call that loads a couple of kernel modules and a couple of other daemons to make this possible, and another script to take it all down when I'm done playing with it.

With NM active, after a spell of time, it "finds" my ax25 config files and says to itself, "ah ha, a network connection", and proceeds to modprobe the ax25 kernel module on the sly, behind my back. It does no harm, but I dislike this behavior very much. Thus, the NM service is never allowed to start on my machine.

Woodrow Ochs
5th January 2009, 02:17 AM
Sorry for the tardiness with this reply. I examined all of those files and found them to be in order (apparently). I installed a fresh Fedora 10 system on a different partition so that I now have two Fedora 10s, one with an active NetworkManager and the other with its NetworkManager removed, and neither now will boot up with an active ethernet connection as a result ( it seems) of my having configured a usb dial-up modem (/dev/ttyACM0) on each.
SUSE 11.1 and Slackware 12.2 are working fine, though. I have looked through /var/log/messages/ without really knowing what to look for. Could you offer any suggestions for that sort of search?

PabloTwo
5th January 2009, 02:54 PM
The only thing that I can think of would be to place the dialup command at the end of the /etc/rc.d/rc.local file. Commands in that file are the last to be executed during the boot up process. Though I use dialup, I have never tried to use it with activation at boot up time, so I've never encountered this problem myself.

As far as I know, if the dial up process was even attempted, which I think it is not in your case, there would be entries in the /var/log/messages file about it.

Vouters
5th January 2009, 03:08 PM
Just a silly question ! Is your modem configured to dhcp serve your Ethernet host ?
Philippe

PabloTwo
5th January 2009, 04:39 PM
Opps... I got confused. It's your ethernet connection not connecting on boot up as you wish it to, not your dial up connection.

Woodrow Ochs
12th January 2009, 02:12 AM
I seem to have found a solution to this problem, a hack solution, unfortunately, and not one which can shed any genuine light on the underlying causes of the anomaly. Anyway, the situation is like this: As the two interfaces, the USB modem (ppp0) and the Ethernet card (eth0) are intended each to operate as clients with IP addresses assigned by DHCP from external servers then both cannot be in operation at any one time without some sort of additional internal configuration (such as masquerading which I am not employing). Thus I must have deactivated one of them (i.e., "ifdown xxxx") before attempting to activate the other (with "ifup xxxx"). With that I had originally been careless at times. The problem which bedevilled me though was that I couldn't get either to boot-up in an active state, and that, it seems, was the result of my having un-checked the box "Controlled by NetworkManager" on the "Devices > Edit > General" window for each of the devices in the "system-config-network" GUI. With that "Controlled by ..." box and with the "Activate devices ..." box checked for "eth0" now, eth0 will boot up in an active state and with an IP number on system boot-up, and this seems to be the case no matter what I do with NetworkManager, though I have not been able to purge NetworkManager completely from this Fedora 10 system or the other one which I installed on another partition for testing. I don't know what is going on or what is not going on, but I can now boot up my system with an active internet connection on eth0 and then switch back and forth from eth0 to ppp0 by first de-activating the one and then activating the other. In the "system-config-network" GUI I must keep the "Activate devices when computer starts" and "Controlled by NetworkManager" boxes checked for eth0, and I have neither of those two checked for ppp0. Because of that, I can control the activation and de-activation of ppp0 through that GUI, but I cannot do so with eth0 (I must use "/sbin/ifup eth0"). My next hurdle will be to integrate this solution with the use of a second Erhernet card and also a bluetooth link for file exchanging on an internal network. Wish me luck. And thanks for your help, Pablo (and you too (Two?), Pablo Two - too?).

PabloTwo
12th January 2009, 03:11 PM
I find the above explanation and description concise and interesting. Not being any kind of network whiz myself, I don't know exactly what/where the conflict is arising from that won't allow both your eth0 and ppp0 to activate at boot up, but a conflict it must be. If both connections provide access to the internet for you, then how would your browser or email program know which to use if both were active at the same time?

I can't duplicate your scenario here to test what would happen if I tried to activate both my ppp0 and eth0 at boot up since I have no eth0 connection to the internet, only dial up, but I can successfully activate them both at boot up if I so choose. Perhaps that's due to the fact that I use a static ip assignment for my eth0 device, while the ppp0 device uses DHCP to obtain it's ip address assignment from my ISP.

As an aside and to address your closing puzzlement- Several years back, in my W95 days, I often played an online game called Heavy Gear 2. Pablo was my chosen screen name on the game servers. When signing up as a member on this forum and picking a user name, for some reason "Pablo" came to the fore, but I then thought to add a "2" to it, as a sort of reincarnation of the original, which ended up being "PabloTwo". It seems to have brought with it... a lot of "the force". :)

cruiser06
13th January 2009, 02:16 AM
Woodrow, this may give you some of the files you were looking for.

man -k . | grep "(5)" | grep conf > ~/ConfigFiles.txt