PDA

View Full Version : How to disable boot splash in Fedora 10



Magice
27th December 2008, 07:48 PM
Hello everyone!
My Fedora box is having some trouble at booting up. The booting process stops somewhere (I guess) when it is starting daemons. However, the beautiful boot splash hides what is going on. How can I disable it and see the boot messages? By the way, since I installed only Fedora on that box (no Windows or whatever), so the thing skips GRUB totally. Is there anyway to let me manually start the daemons?
Thank you!

Jake
27th December 2008, 10:56 PM
well, you could hit Esc, this takes you to verbose (What you need). or tap the upkey untill you see grub and remove quiet and rhgb from the kernel line.

Also when you see the "press "i" to enter interactive startup" press "i" and it will let you choose what to start and what not to start.

David McCracken
20th May 2009, 12:28 AM
Even if you have just Fedora, grub still boots the kernel. It's just that your grub.conf (in /boot/grub) contains only one OS option and a timeout of 0. But you can still stop it. Just start pressing some innocuous key like up arrow before your BIOS launches grub. Grub will respond by showing you the one OS, Fedora. At that point, press 'e' to edit. Then arrow down to highlight the "kernel /vmlinuz..." line. Press 'e' again to edit this line. The changes you make at this time are temporary. Delete rhgb and quiet at the end of this line. Append confirm to the line. Press enter then 'b'. This may be the only way to get interactive boot with Fedora 10 because it has a startup script bug.

Loki1950
20th May 2009, 12:37 AM
I have been able to get interactive boot by spamming the "i" key before udev starts.

Enjoy the Choice :)

klingoncowboy4
20th May 2009, 10:42 PM
Given your problems there should be a warning icon (a triangle with an ! in it) in the GDM before you login. Clicking on that should load up a complete record in the format you are searching for of load so you can look for [FAILED]

klingoncowboy4
20th May 2009, 11:08 PM
btw is there a way to have it so that the splash screen is always disabled or do I need to manually redo thed delete rhgb and quiet for every kernal update

ozjd
20th May 2009, 11:30 PM
btw is there a way to have it so that the splash screen is always disabled or do I need to manually redo thed delete rhgb and quiet for every kernal update

You need to make the changes David listed above in /boot/grub/grub.conf.

moniker117
21st May 2009, 07:30 AM
btw is there a way to have it so that the splash screen is always disabled or do I need to manually redo thed delete rhgb and quiet for every kernal update

I have edited my /boot/grub/grub.conf file and removed the rhgb parameter from the kernel and entries made by updated kernels seem to keep rhgb out. Therefore, I don't suspect you would have to remove it everytime there's a kernel update.