PDA

View Full Version : system-config-services hangs



dunnigan14
27th December 2008, 06:07 PM
Hello all.

Previously system-config-services just did not work due to the DBUS issue.

Now when I start system-config-services as root or any other user when GUI opens and loads the list of services, but everything is greyed out and the mouse pointer has the spinning blue dots. This does not go away after any amount of time.

I have run it from the command line and there is no output there.

I also have a fully updated system a 'yum update' as root says "No Packages marked for Update".

Any ideas on why this might be happening?

Thanks for all the help.

marcrblevins
28th December 2008, 01:56 AM
Its working, I waited for a minute while its loading the list of services. Weird thing was it did not ask me for the root passward. Started from my regular user's terminal.

I'm using kernel:


[marc@kiriyamablevins ~]$ uname -r
2.6.27.9-159.fc10.i686
[marc@kiriyamablevins ~]$

dunnigan14
28th December 2008, 05:29 PM
Mine is still not working. I left it over night and it still has all options, buttons, menus, etc. greyed out, and the mouse pointer has the nice blue dots spinning around it.

I am using the same kernel



#> uname -r
2.6.27.9-159.fc10.i686


I thought maybe SELinux was the problem so I disabled it. That did not work.

I strace'd the process to see if there was some file maybe that it cannot find or something like that. It looks like based on the strace that system-config-services opens up some sockets to and ends up in a loop reading and writing to the sockets.

Any help or thoughts would be great. I will continue to look into this problem as well.


Thanks!!!

gong
28th December 2008, 05:39 PM
hi, plz search the forum.

i read a topic last time, and that solved my issue by modifying a python script.

dunnigan14
28th December 2008, 06:36 PM
I have searched the forums for all threads containing "system-config-services" going back to May of 2008. I have not seen anything saying to edit a python script.

I have seen a work around to edit /etc/dbus-1/system.conf file. But this was a suggestion to work around the DBus issue.

SlowJet
28th December 2008, 07:51 PM
setenforce 0
yum clean all --enablerepo=updates-testing
yum update --enablerepo=updates-testing
touch /.autorelabel
reboot

after rebooting, in a root terminal
system-config-services
(it will still take about 30-45 seconds.)

SJ