PDA

View Full Version : RPM installer



Gundumfx
27th December 2008, 07:22 AM
well i know that when you double click a RPM in gnome it auto installs with all deps for you, how can i do that in fluxbox? if i try to double click a RPM in fluxbox with nautilus i get a

"local file installer is running when the session is not local"
"this normally indicates a bug with ConsoleKit or the way your session has started"
i'm pretty sure its the latter of the indications, but i'd still like to know how to fix it.

Demz
27th December 2008, 07:32 AM
i would assume for example by using the rpm -i <packagename> command

Gundumfx
27th December 2008, 07:39 AM
yeah i know that, but it doesn't install dependancies, the gnome one does, i need that.

Demz
27th December 2008, 07:55 AM
what are the deps it needs to install the rpm package you want?.. easy thing i would do is log into Gnome an install it then log back into fluxbux

Gundumfx
27th December 2008, 08:06 AM
i didn't install gnome and don't want to, im a minimalist, and im trying to install opera which is asking for a dogpile of deps:


[Locke@Jesus Downloads]$ sudo rpm -ivh opera*rpm
[sudo] password for Locke:
error: Failed dependencies:
libICE.so.6 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libSM.so.6 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libX11.so.6 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libXext.so.6 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libXt.so.6 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libc.so.6 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libc.so.6(GLIBC_2.0) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libc.so.6(GLIBC_2.1) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libc.so.6(GLIBC_2.1.2) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libc.so.6(GLIBC_2.1.3) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libc.so.6(GLIBC_2.2) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libc.so.6(GLIBC_2.2.3) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libc.so.6(GLIBC_2.3) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libdl.so.2 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libdl.so.2(GLIBC_2.0) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libdl.so.2(GLIBC_2.1) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libgcc_s.so.1 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libgcc_s.so.1(GCC_3.0) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libgcc_s.so.1(GLIBC_2.0) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libm.so.6 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libm.so.6(GLIBC_2.0) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libpthread.so.0 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libpthread.so.0(GLIBC_2.0) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libpthread.so.0(GLIBC_2.1) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libpthread.so.0(GLIBC_2.2) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libpthread.so.0(GLIBC_2.3.2) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libqt-mt.so.3 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libstdc++.so.6 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libstdc++.so.6(GLIBCXX_3.4) is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
libz.so.1 is needed by opera-2:9.63-2474.gcc4.shared.qt3.i386
[Locke@Jesus Downloads]$


and yes, my hostname is Jesus

also i'm pretty sure it really just wants 1 or 2main package, and the rest are deps of those, but idk which.

Demz
27th December 2008, 08:26 AM
what if you install the deps first prior to installing the actual package . since i do not use Opera Browser i dont know, this maybe better left for scottro

but do you have glibc installed?

sidebrnz
27th December 2008, 08:42 AM
Don't use rpm, use yum because yum knows how to get the dependencies.

Gundumfx
27th December 2008, 08:45 AM
yum doesn't have opera. and yes i have glibc

Demz
27th December 2008, 08:51 AM
what about gcc do you have that

Gundumfx
27th December 2008, 09:00 AM
yes i do. but my issue isn't that i can't install it, its that i want the deps auto installed.

Demz
27th December 2008, 09:03 AM
only best way to do i can think of is thats to get into Gnome or find these deps at rpmfind.net an install them all via command line

Gundumfx
27th December 2008, 09:10 AM
sigh... i'll live without auto deps and gnome =( though the dep thing is not a gnome specific function im sure, i just don't know what to do to enable it other than install gnome

Demz
27th December 2008, 09:13 AM
thats the only thing i can think of. since Fedora/Redhat is a Gnome centric Distro it may depend on Gnome being installed anyway for these deps to be cured ..either Gnome or KDE

Hlingler
27th December 2008, 09:18 AM
What the hell is going on here? This is so simple: open a terminal, then:
(1) cd /home/Locke/Downloads
(2) [sudo OR su -c] yum --nogpgcheck localinstall opera*
(3) Done.

V

Gundumfx
27th December 2008, 09:27 AM
I love this forum, and especially its random heroes :) makes my inner penguin wobble in glee