PDA

View Full Version : Fedora Core 10 on HP Pavilion dv6137 tx -- series of problems



maverick280857
25th December 2008, 05:09 PM
Hi everyone

I've been using Fedora Core 10 on an HP Pavilion dv6137tx laptop for about 3 weeks, and its generally responded splendidly. But there are a few problems that I have been facing, and I have not found any solution yet. They are listed here in order of decreasing annoyance :p

Problem 1: Fedora freezes or the system becomes VERY slow and has to be manually shut down using the power button.

Usually, this happens during normal operation and at other times, but occasionally the system freezes during a blank screen saver/screen lock and it takes several minutes to show the login screen. On all such occasions, the hard disk light is 'on' almost continuously and I can even hear the hum of the hard disk--as if some data transfer is going on.

As I always have to use the power button to shut down the system by brute force, there is no way I can look at errors or other messages displayed on screen at this time, before shutting down. So I don't know what the cause could be :(

Problem 2: Jumping cursor. (Don't know what else to call it)

When I am typing something in a text window either in firefox (like this forum thread) or in gvim, kate, kile, kdevelop or virtually anything else, the cursor sometimes jumps around all over the place and I end up typing in the wrong place. This usually happens when I am typing fast (and no, I don't accidentally hit tabs, spacebars or arrow keys, or the touchpad) but if I am super slow, this never happens. I don't know if this is some kind of keymap problem or what...can't find any reason for this...as you can appreciate, it is quite irritating sometimes. It has already happened four times in the course of typing this thread :rolleyes:

Problem 3: linuxdcpp downloads file lists, but not not files.

I've dedicated a thread to this problem: http://forums.fedoraforum.org/showthread.php?t=208363. Its not a wireless-related problem though, as I can't get it to download files even on a wired connection.

Problem 4: Errno 256 in yum: I've looked at several forum posts here, but somehow I don't have a fix for this yet, so I can't use the graphical update manager. I make do with text based yum, but I still want to resolve this problem.

Problem 5: Pidgin crashes way too much in Fedora 10: Why?

Please do reply to this thread if you have any idea as to the cause of these problems and/or have a solution.

Thanks in advance,
Cheers
Vivek

maverick280857
26th December 2008, 05:36 AM
Could someone please help, esp with problem 1?

vchudnov
26th December 2008, 10:46 PM
I am having problem 1 as well (system being extremely slow, the hard disk light on continuously) as I am trying to upgrade my laptop (Sony VAIO VGN-S580) from Fedora 9 to Fedora 10. Earlier this morning I estimated that I got maybe 5 packages installed from the DVD in one hour! Maybe there is a kernel argument we need to pass to the installer?

rthomas
26th December 2008, 11:17 PM
I have also noticed FC10 to be slow on occassions, though I do not get anything like the delays which you're talking about. I might get 10/20 second delays now and again.

Personally I suspect it is something to do with hardware drivers, though I can not be sure. Have you tried installing your graphics card drivers, or are you using the 'default' drivers? Try installing the nVidia drivers for your card.

Sorry I couldn't be of more help :(

rthomas
26th December 2008, 11:21 PM
Oh, regarding the "Jumping Cursor"; I am running FC10 on an HP Pavillion dv9000 and I also experienced this, but diagnosed it as sensitive hardware; I don't believe it has anything to do with Fedora.

Try disabling the laptop's mouse/touchpad, and switch to a USB mouse. That will narrow the problem down to hardware or software. I'm guessing hardware ;)

vchudnov
26th December 2008, 11:50 PM
I've tried a hard reboot and running the installer in text mode. The same slowdown occurs. I doubt it's the graphics driver, though I could well believe it could be the hd driver....

afwong15
27th December 2008, 12:11 AM
I just posted a thread about problem number 2, I think it goes beyond the mouse itself, since my system (Thinkpad X61) hangs when I try to restart my computer.

maverick280857
27th December 2008, 07:00 AM
Thanks everyone for replying. To answer some specific points raised in previous posts:

1. I have the nVidia driver installed and correctly configured.

2. I am not passing any arguments to the kernel explicitly.

Please keep the posts flowing. I don't want to do a full system reinstall unless its absolutely required, as I will have to use the recovery DVDs supplied with the laptop to first restore windows, and then repartition the drive manually to install Fedora (I have to keep windows for some warranty issues, although I never use it :rolleyes:).