PDA

View Full Version : VNC Server Setup



Surajprakash
25th December 2008, 12:31 PM
Hello,

I am configuring `1st time VNC Server on Fedora. I am using Fedora 10. Pl. explain me how to do. ?

I done few changes from some forms but i can not access my linux box from out side.

Thanks

Surajprakash

notageek
25th December 2008, 12:56 PM
Hi try the following



# yum install vnc-server
# yum install vnc


Edit the config file


# vi /etc/sysconfig/vncserver

Uncomment the sections with VNCSERVERS=1:myusername and VNCSERVERARGS, replace "myusername" with the username you'd like to give access through vnc.

Next using the login of the user try the following:


$ vncserver
You'll be asked to set a new password for the user, set a suitable password. Startup files will be written to /home/user/.vnc/.... etc

Check whether the server is up by running "nmap localhost" which should give you something like

5901/tcp open vnc-1

Stop the server from the user :

$ vncserver -kill :1

Then try the following:


# service vncserver start

And don't forget to check "man vncserver" if you get stuck

Hope this helps.

Surajprakash
25th December 2008, 01:27 PM
Hello,

thanks for reply

I done same as you guide.
but when i goes to start vnc server it shows failed.


Surajprakash

notageek
25th December 2008, 01:34 PM
Yes I know, I realized the same, the difference is the /home/user/.vnc/... startup files, which are written for the first time when you run vncserver "manually" i.e login as the user in a terminal and run vncserver.

Follow the screen, you'll be asked to set a password and you should get some messages that say: "Creating startup files... etc" "Starting applications specified..." "Log file is ..."

IMHO server vncserver start should be writing them, but it doesn't. Check the log file in /home/user/.vnc/localhost.localdomain:1.log (or yourhost.domain:1.log)

Surajprakash
25th December 2008, 01:54 PM
Hello,

I still confuse to configure Server.
I want to access (from out side network) my Fedora 10 box with same as when i m setting in front of my computer.

Surajprakash

stlouis
25th December 2008, 03:38 PM
Take a look at these links:

http://forums.fedoraforum.org/showthread.php?t=208670

http://fedorasolved.org/network-solutions/vncserver-setup


For which user are you starting VNC for? Standard user or ROOT (I hope not )?


Try logging on to the server as your desired user, and kill any active VNC Servers for that user.

Next, type "vncpasswd" for your user, and set the password. You will have to verify

Next, edit the .vcn/xstartup file in your home directory, if you do NOT want to see the default Grey Screen... This is where you set VNC to start kde or gnome... (details in links above).

If you are connecting from Windows, I recommend that you use Ultra VNC as your client.

Try to START VNC for you user. Do you still get an error?


Once you get VNC Working, you may have it start on boot by customizing the vncserver file in the /etc/init.d/rc.d directory and linking it to the appropriate run levels manually or enabling it with the "chkconfig" command.


have fun.