PDA

View Full Version : Unable to Boot Either WinXP or FC-9



mike191
24th December 2008, 12:18 AM
I have been successfully running a dual boot desktop (Dell dimension 9200) system with Windows XP and Fedora Core 9 for many months. The PC came with Win XP, and I installed FC 8, then upgraded to FC9 online.

When I powered up the system a couple of days ago, it suddenly came up as far as GRUB at the top of the page, with no OS choices available. The only way I can get a response is by entering "control-alt-delete" which restarts, and I can enter F12/F2 to examine the setup. I see nothing obvious, but can not get either Windows or Fedora to boot. I don't know where to even begin with this problem.

Thanks in advance for any suggestions on how to approach this!

stoat
24th December 2008, 12:29 AM
Re-install the GRUB boot loader.

mike191
28th December 2008, 06:04 PM
How do I reinstall GRUB? I tried using the Fedora DVD (8 & 9, both from Linux Central). The FC9 DVD would not boot and the FC8 DVD looked like it was going to directly install fedora again. It was not clear how to pick just the GRUB boot loader. Should I prepare a bootable disk from the fedora website using another computer? Obviously, I'm using another computer at the moment. :)

Thanks again for your help!

stoat
28th December 2008, 06:18 PM
I tried using the Fedora DVD (8 & 9, both from Linux Central). The FC9 DVD would not boot and the FC8 DVD looked like it was going to directly install fedora again.Well, the classic method is (or would have been) to boot with your F9 DVD and choose "Rescue installed system". From there you follow along with it to the sh prompt and enter chroot /mnt/sysimage. At the next sh prompt, enter grub-install /dev/sda. If you get the "No corresponding drive in BIOS" error, then do it again with the --recheck option like this: grub-install --recheck /dev/sda.

However, after what you just said, here is another idea. On that computer you're using now, download and create a Super Grub Disk (http://www.supergrubdisk.org/). It's a free utility that can not only emergency boot your wounded system (if it is still capable of booting), but it can also re-install the GRUB boot loader. It is not a beautiful GUI point-and-click app. It is menu-driven. The menus can be somewhat maze-like until you learn your way around. There is documentation available at that website. Anyway, it's still a valuable utility that everyone using a GRUB-booted Linux should possess, as you have now found out.

mike191
1st January 2009, 09:26 PM
Thanks for the great wealth of information. I made the supergrubdisk as you suggested and tried to boot from that. I downloaded the super_grub_disk_0.9774.iso to cd from a different computer and then put it in the cd drive of the wounded one and tried to boot. The result was the same: the system came up to GRUB as before and went no further. Should I be doing something different with the iso file, or does this imply that the computer is not bootable by any "normal" method? I think the hardware is intact, and everything is backed up, but this looks grim. Thanks for any ideas. :confused:

stoat
1st January 2009, 09:58 PM
For the computer to skip past the CD and boot the hard drive like that suggests two possible things to me: 1) the BIOS is not set to boot first from the CD drive, or 2) the CD was not burned correctly. Either way I run the risk of insulting you by suggesting those two basic things, but people do both of them all the time.

First ensure that a known bootable CD or DVD will boot in this computer, or enter the BIOS setup and look at the boot device order and correct it if necessary. If all that was okay, then ensure that you burned the ISO to the disk as a image project and not as data. People often burn the ISO file itself to the disk as data. Exploring the disk with a file manager reveals only the original ISO file. Another common mistake that people do is to extract the files from the ISO and burn them to the disk. But that never works because of the unique way that CDs boot. The ISO should be burned to disk by looking for a burning option in your software worded similarly to "burn as an image". No offense intended.

mike191
4th January 2009, 06:41 PM
No offense taken at all. I did not burn the cd as an image. I was suspicious of that since I have not done that before and I knew the BIOS was correct. I corrected the cd image. It now tries to boot, but immediately comes up with the message "Missing operating system" and goes no further. Thanks for your patience. :confused: