PDA

View Full Version : gdesklets on FC2



JonR
19th August 2004, 03:00 PM
I'm trying to get gdesklets to run the GoodWeather display. I've installed gdesklets 0.30 and gdesklets-GoodWeather rpms using yum from Dag - no errors.

I can start gdesklets ($ gdesklets start) and the gDesklets shell icon appears at the right of my Gnome taskbar. When I right click and select manage displays I find GoodWeather ver. ??? is there under "uncategorized". If I try to run GoodWeather I get a messagebox with:

Invalid display file.
'/usr/share/gdesklets/Displays/GoodWeather/GoodWeather.display'
The display file contains invalid data and could not be loaded.

Clearly I'm doing something wrong, but what? :confused:

yur1022
19th August 2004, 09:06 PM
Well, there seem to be some problems with gdesklets 3.0 being discovered. Not being able to run GoodWeather, according to at least a handful of users, is one of the problems. I am having the same problem. When I did google-search with Unknown target type "metha", I found this issues discussed in a French gdesklets forum, in which a few tips were given, but they did not work. I hope the GoodWeather author (or an expert of python) figures it out and provides a solution in the near future.

yur

JonR
19th August 2004, 10:41 PM
thanks yur, that's useful to know.
jonr

yur1022
20th August 2004, 08:37 PM
Someone in the gdesklets community informed me of how to fix this mistake in GoodWeather display. In the GoodWeather.display file (located in /usr/share/gdesklets/Displays/GoodWeather/ or ~/.gdesklets/Displays/GoodWeather), "meta" is misspelled as "metha". So, open the GoodWeather.display file using your favorite editor (and be sure to have a proper permission; I mean do it as su if it is in /usr/share/...), and search/replace metha by meta.

yur

JonR
20th August 2004, 08:42 PM
Thanks Yur, I just found it too! Edited the .display file to correct the tag name and everything works fine. Thanks for your help.

jonr

desipher
20th August 2004, 11:29 PM
Having issues trying to run qdeklets on FC2 all together. When I try to run err is

desklets-goodweather-0.3-0.1.fc2.dag.noarch.rpm: V3 DSA signature: NOKEY, key ID 6b8d79e6
error: Failed dependencies:
gdesklets is needed by gdesklets-goodweather-0.3-0.1.fc2.dag
gnome-python2-gnomevfs is needed by gdesklets-goodweather-0.3-0.1.fc2.dag.

ok so I run gnome-python2-gnomevfs so I get the err for more dspendencies.


error: Failed dependencies:
libORBit-2.so.0()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libbonobo-activation.so.4()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libc.so.6()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libc.so.6(GLIBC_2.2.5)(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libdl.so.2()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libglib-2.0.so.0()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libgmodule-2.0.so.0()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libgnomevfs-2.so.0()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libgobject-2.0.so.0()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libgthread-2.0.so.0()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libm.so.6()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
libpthread.so.0()(64bit) is needed by gnome-python2-gnomevfs-2.0.0-4.1
When I install gdesklets err I get is
gdesklets-0.26.2-1.1.fc2.dag.i386.rpm: V3 DSA signature: NOKEY, key ID 6b8d79e6
error: Failed dependencies:
gnome-python2-gconf >= 2.0 is needed by gdesklets-0.26.2-1.1.fc2.dag

imdeemvp
22nd August 2004, 06:20 AM
i download it:
[root@localhost gDesklets-0.30]# yum install gdesklets
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Dag RPM Repository for Fedora Core
Server: Fedora Linux 2 - i386 - freshrpms
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
Dependencies resolved
I will do the following:
[install: gdesklets 0.30-1.1.fc2.dag.i386]
Is this ok [y/N]: y
Downloading Packages
Getting gdesklets-0.30-1.1.fc2.dag.i386.rpm
gdesklets-0.30-1.1.fc2.da 100% |=========================| 389 kB 00:10
Running test transaction:
Test transaction complete, Success!
gdesklets 100 % done 1/1
Installed: gdesklets 0.30-1.1.fc2.dag.i386
Transaction(s) Complete

and i also downloaded the sensors and installed them then i when i openen gdesklets and select run selected display for example info display nothing happens....package (http://gdesklets.gnomedesktop.org/categories.php?func=gd_show_app&gd_app_id=107)

what did i do wrong :confused:

imdeemvp
22nd August 2004, 07:18 AM
never mind..........fix it!

desipher
22nd August 2004, 01:06 PM
I'm having problems when I run gdesklets it says "gdesklets start
connected to daemon in 1 milliseconds" and never runs.

marco ferretti
3rd September 2004, 10:09 AM
Hi there all.Sorry if this question seems stupid but, foregiveme I a newby.

I am running a fedora core 2 box . I downloaded gdesklets 0.30 and compiled successfully but when I run "gdesklets start" I get "Cannot establish connection to daemon : timeout"

I don't know where the logs are (so that I may try to solve the problem with some googling) , plese help

TIA

marco

bu66le
3rd September 2004, 10:45 AM
gDesklets 0.30 - The Missing Manual: http://fatboy.ucd.ie/gdesklets/
I use gdesklets 0.26, everything works fine :)

imdeemvp
3rd September 2004, 10:46 AM
marco ferreti,

you are in luck there is a couple of threads about this topic

thread 1 (http://www.fedoraforum.org/forum/showpost.php?p=94345&postcount=3) and thread 2 (http://www.fedoraforum.org/forum/showthread.php?t=21516)

satified???....have a snickers bar :D