PDA

View Full Version : System freezes when going to the login screen



inha
19th August 2004, 08:47 AM
it shows the screen right before the fedora login screen comes where there's some text like my ip and tettgang i686 and stuff. then it apparently tries to start the x to load the fedora login screen but the screen goes blank and goes back to the first screen.

I fiddled around with my system last night and I probably messed something up then. I compiled and installed the latest kernel using ilja's instructions. no errors there, the only error message I got was when I was configuring grub but it didn't seem to have anything to do with the x. then I removed some packages I didn't need, some kernels I didn't use anymore, games, text editors but I don't think I removed anything that could cause this. and I also cleared the /usr/tmp (not sure about the path) since synaptic and rpm complained about having no diskspace left.

being the noob I am I have no idea on how to start fixing this. I've got the rescue disk so using that I should be able to check the system logs and such.

could someone help me out with this. none of the kernels I have on goes beyond that point in the startup.

tashirosgt
19th August 2004, 02:34 PM
Can you use the rescue disk, login in the text mode and so startx, just to verify that this is indeed an Xserver problem?

inha
19th August 2004, 03:14 PM
I just used it and checked the logs.

This seems to be the problem(from messages.log):

mdmpd: mdmpd failed (I'm not sure if this is relevent)

gdm_slave_xioerror_handler: Fatal X error - Restarting :0

and then it repeats the gdm line.

when I try to start the system it goes to a text-login screen and then the monitor goes blank for some seconds and the restarts. it's in a loop of some sort.

tashirosgt
19th August 2004, 04:52 PM
It would be interesting to know what mdmpd is. It might be a daemon associated with "multiple program multiple data", which suggests you have a multiple processor kernell? But it looks like the problem is with the Xserver. What does your /etc/X11/xorg.conf file say?

You could also look at the recent thread started by treedstang in the Hardware section.

tbossert
19th August 2004, 04:58 PM
What videocard are you using? Cause I know whenever I add a new kernel with my nvidia card if I dont reinstall the drivers I get the same thing you are seeing with X crashing . Just a though since your xorg.conf might be calling a driver that hasent been recompiled for the new kernel.

inha
19th August 2004, 05:00 PM
I don't have a multiprocessor kernel.

there's this error in Xorg.0.log:

Cound not init font path element unix/:7100, removing from list!

Fatal server error: could not open default font 'fixed'

I'll recheck if there's anything else in there.

inha
19th August 2004, 05:01 PM
What videocard are you using? Cause I know whenever I add a new kernel with my nvidia card if I dont reinstall the drivers I get the same thing you are seeing with X crashing . Just a though since your xorg.conf might be calling a driver that hasent been recompiled for the new kernel.

I've got a geforce ti 4600 but I don't have the nvidia drivers installed.

tbossert
19th August 2004, 05:02 PM
thats the same card I have. Check your xorg.conf to make sure its loading the nv module under your videocard instead of the nvidia since you do not have the nvidia drivers installed.

inha
19th August 2004, 05:20 PM
it is loading the nv module.

I don't know how to print it from the rescue mode and I couldn't copy the xorg.conf to a floppy since mount didn't work because apparently there was no fstab. There's no way to access the hd linux is on from windows I suppose. Or is there? EDIT: there is. nevermind.

that unix/:7100 error in the x log is the same font that is mentioned in xorg.conf, could that have anything to do with this?

I googled mdmpd and it's some multi path device monitor. It shouldn't have anything to do with this.

inha
19th August 2004, 05:26 PM
here's my xorg.conf

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "fi"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor 1024x768"
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

here's the whole thing.

tbossert
19th August 2004, 05:29 PM
is that the complete xorg.conf cause it seems to be missing some info

inha
19th August 2004, 05:42 PM
I managed to log in even though the screen kept going off and on and when I went to initlevel 3 it froze at:

Starting mdmpd: Kernel md module does not support events

then I ctrl-c'd and tried to go to init level 5 and it froze at the same point.

tashirosgt
19th August 2004, 05:58 PM
Could it be this bug?

http://bugzilla.redhat.com/bugzilla/long_list.cgi?buglist=122691

inha
19th August 2004, 06:31 PM
maybe but that bug shouldn't cause problems like this.

http://www.linuxquestions.org/questions/showthread.php?s=&forumid=2&threadid=156348

the guy in that thread had similiar problems. I tried all that there was suggested in there but still no go.
service xfs restart gives an unknown service error
clearing tmp didn't help
changing unix/:7100 to 7110 didn't help

startx gives an error like this: XIO: fatal IO error 104 (connection reset by peer) on X server ":0.0"

also found this in messages: "xfs: cannot establish any listening sockets" but then it's followed by xfs startup succeeded

inha
19th August 2004, 07:00 PM
From the info I've managed to gather this might be a xfs issue caused by a full boot section. I'll try to free up some space and see if it starts working

inha
19th August 2004, 07:30 PM
Problem solved: The whole deal was caused by the boot section being full (not sure of the term here. not the home partition but the other one). When I compiled that new kernel it took filled the whole partition. I cleared /usr/src/redhat/BUILD/kernel-versionnumberhere and it helped. I have no idea if that affects the kernel so I'll have to check that out later.

Earlier my pissedoffness escalated to the point that I had to go out and buy a six pack to avoid causing physical damage to my comp. This was obviously a good choice since I got it fixed by the time I was having my second beer.

I recommend fine lagers for fixing any linux problems.