PDA

View Full Version : what is /usr/libexec/gconf-sanity-check-2 ?



carlainz
21st December 2008, 07:54 PM
Hi , after update my system F10 x86_64 , at the first reboot i have this message and after black screen ....:(

There is a problem with the configuration server. (/usr/libexec/gconf-sanity-check-2 exited with status 256)


any help ? what is this gconf-sanity-check-2 ?

thanks

Firewing1
21st December 2008, 09:09 PM
I can't say for sure, but I'd imagine it checks your gconf configuration (gconf is the Gnome equivalent of the Windows registry, but it's only used for storing your preferences things like about font sizes, current theme, etc) and it's exiting with status 256 because it found a problem. Try backing up your ".gconf" folder like this:

mv .gconf gconf-bak
That will erase all your preferences, but if you need them back just remove the new ".gconf" folder which is auto-generated and replace it with the stored backup (gconf-bak).
Firewing1

egurski
2nd April 2009, 09:49 PM
I just started having this problem with FC10 X86-64 and tried your solution without success.

Any other suggestions?

Thanks

vednth87
3rd April 2010, 06:10 AM
I faced a similar problem which I solved by changing the permissions of /tmp directory to rwx-rwx-rwx.

jfoderaro
25th April 2010, 06:44 PM
I faced a similar problem which I solved by changing the permissions of /tmp directory to rwx-rwx-rwx.

That fixed it for me as well. Thanks for the post.

I wish gconf-sanity-check-2 was a bit more verbose when it found a problem.

charan2987
6th July 2010, 01:42 PM
Hi,

I'm running the FC13 and this issue has come up...and it says

There is a problem with the configuration server. (/usr/libexec/gconf-sanity-check-2 exited with status 256)

on closing that, the login screen comes and if I try to login, the same alert pops up and the screen is blank when logged-in via the GNOME and it if tried via the KDE or KDE (Failsafe) it returns to the login screen.

Someone please help :(

wolvarine
8th September 2010, 07:47 PM
Hi,

@charan2987


i don't know if u are still facing da problem !!


this is my first post by da way!!! but i had also got the same error when i have wrongly set up TMPDIR parameter in bash_profile.

i had corrected the entry and the problem is solved. i can log in now.

just think n check for any latest changes u have done in system configuration

refert if it works !!! :D

charan2987
9th September 2010, 02:58 AM
@wolvarine - A quick question here....how to change the parameter set wrongly on the bash_profile when I am unable to go past the login screen cos of this error popping up :confused::(

N as I did not know wat to do or find a solution online then...I had to reinstall the OS....!!!

Thanks

wolvarine
10th September 2010, 08:27 AM
@charan2987


well i had done changes to bash profile of oracle user account. and for other account which i had created during os installation i could able to login. so i had done changes.

But in your case as i don't know what exactly you might have done configuration changes,

i can not comment.

have u tried logging from another account if u had??

but it doesn't matter any more now. not after you have re-installed OS .

ny ways u can still google on what could have been done? if u had a time !!! :D

cheers"""

thanks

tanveerall
14th September 2010, 04:08 PM
Hi Every body

Today I also started getting the same problem on my Fedora 13 machine i.e.

There is a problem with the configuration server. (/usr/libexec/gconf-sanity-check-2 exited with status 256)

As per my findings, I am getting this problem only because I have accidentally changed permissions on /tmp folder. The owner of /tmp folder become other than root and also no other user have read, write or execute rights on /tmp folder. I just changed its owner again to root, group also to root and gave every body read, write and execute rights.

chown -rwx root:root /tmp
chmod 777 /tmp

Take Care

Pokny
22nd April 2011, 10:59 PM
Absolutely Folks: The /tmp directory is the problem. When I set up Fedora 14 I made the /dev/[tmp] FS too small so when I decided not to mount it the /tmp dir had the wrong permissions.
Then I checked in here and SHAZAM! (Captain Marvel appeared).
Anyway my root dir is plenty large enough to hold the tmp dir.

Cheers!

COKEDUDE
10th August 2011, 11:13 PM
Thx to everyone that pointed out the permission problem with /tmp. All you need to do is this as root:


chmod a+rwx /tmp


Hi Every body

Today I also started getting the same problem on my Fedora 13 machine i.e.

There is a problem with the configuration server. (/usr/libexec/gconf-sanity-check-2 exited with status 256)

As per my findings, I am getting this problem only because I have accidentally changed permissions on /tmp folder. The owner of /tmp folder become other than root and also no other user have read, write or execute rights on /tmp folder. I just changed its owner again to root, group also to root and gave every body read, write and execute rights.

chown -rwx root:root /tmp
chmod 777 /tmp

Take Care

This does not work. There is no -rwx options. Read the man pages.