PDA

View Full Version : disable screensaver while watching video



kilgor
21st December 2008, 07:32 PM
Hi,

The screen saver starts after the specified period as expected. But it also does this when a video is running, which is not expected. It's a PITA to watch a movie, if you have to wiggle the mouse periodically.

I started having this problem after some update a few months ago, then using F9. Now I'm on F10 and this problem still persists. I also have this problem with my eee pc 901, which has F10 and whatever video driver it installed as well as on my PC which is using the nvidia blob driver from rpmfusion.

Anyhow, this problem appeared on my PC at some point thanks to an update, probably kmod-nvidia update. I assume this can be fixed with a driver setting in xorg.conf, but can't find what it might be. I really tried googling and searching these forums, to my surprise without luck. Any pointers?

Dangermouse
21st December 2008, 09:53 PM
Hi
you didnt mention what you were using to play video, but if its totem just go to preferences in totem, its an option to disable screensaver

kilgor
28th December 2008, 12:10 PM
Hi
you didnt mention what you were using to play video, but if its totem just go to preferences in totem, its an option to disable screensaver
I'm using mplayer, but thanks for the hint. The mplayer option is: -stop-xscreensaver.

I added "stop-xscreensaver = yes" to the global /etc/mplayer/mplayer.conf file and problem solved. Thanks!

Though earlier this wasn't required, the nvidia driver did something it doesn't do anymore.