PDA

View Full Version : Java 1.4.2 on FC9 Help



louiss3000
21st December 2008, 06:28 PM
I have an application, JavaHMO, that requires Java 1.4.2.06. I have tried installing this on FC9 with no luck. The Java install fails with "tail: cannot open +480, no such......"

I have tried a 'space' between the + and the 480, but then I get 2 error messages. 1 saying can't open +, and another saying can't open 480.

I recall having this issue when installing on FC6, but I cannot recall how it was resolved.

Any and all help appreciated

LS

zx5000
21st December 2008, 06:39 PM
How are you starting the program?
Perhaps you can just unpack your 1.4.2 in it's own folder rather than run the installer.
I like to do /opt/jdk ...

Usually fedora has it's JRE something like this:
[jpowell@tc4400 logs]$ which java
/usr/bin/java

lrwxrwxrwx 1 root root 22 2008-07-16 07:54 /usr/bin/java -> /etc/alternatives/java
lrwxrwxrwx 1 root root 39 2008-09-21 12:59 /etc/alternatives/java -> /usr/lib/jvm/jre-1.6.0-openjdk/bin/java

You might try launch it with $PATH_TO_YOUR_1.4.2JRE/java ... or you may need to set JRE_HOME / JAVA_HOME to the appropriate path.

HTH