PDA

View Full Version : sound issue after upgrade



dsharp
17th August 2004, 04:31 PM
I've seen multiple posts about this problem but no solutions that work for me.

Ever since I've upgraded from Redhat 8 to Fedora Core 2 I have sound problems.

When logging in to a KDE desktop I get the following error:

device /dev/dsp can't be opened
The sound server will continue, using the null output device.

Also when I try to play MP3s using XMMS I get the following error:

Please check that:
Your sound card is configured properly
You have the correct plugin selected
No other program is blocking the sound card

If any can help I would appreciate it.
THANKS!

PsyGhost
17th August 2004, 04:46 PM
Are you using the default fedora kernel?
Can you play sound in GNOME?

dsharp
17th August 2004, 05:10 PM
Not sure if I'm using the default kernel.....my kernel version is 2.6.5-1.358

When I use the gnome desktop I don't get the "device /dev/dsp can't be opened" but I still get the other message when I try to play an MP3 using XMMS.

Thanks.

PsyGhost
17th August 2004, 05:16 PM
Yes it is the default kernel.
Redhat decided to dtop the MP3 support in their distribution.
So check if you can play a wav sound.
If you can I'll guide you how to enable mp3.

dsharp
17th August 2004, 06:43 PM
Can not play a wav file. I get the same message as before.

All of this was working before I upgraded. Shouldn't it work now!

Thanks.

ghaefb
17th August 2004, 06:48 PM
What kind of sound card are you using?
Run: system-config-soundcard
And check if you sound card is even detected.

dsharp
17th August 2004, 06:55 PM
system-config-soundcard command returns message "No sound cards were detected."

I think I have a Crystal sound card that is build into the Intel motherboard.

In windows when I look at the properties it shows:

Crystal Semiconductor
Intel 82371AB/EB PCI
Crystal WDM Audio Codec

Hope you can help me.
Thanks.

ghaefb
17th August 2004, 07:01 PM
Did your soundcard got detected in RedHAt 8 ??

As I can see ALSA does not support your "Crystal Semiconductor" sound card. :(
Check for your self here -> http://www.alsa-project.org/alsa-doc/

dsharp
17th August 2004, 07:15 PM
I assume it was detected/supported in Redhat 8. I know it worked. I didn't get any of the messages I get now and I was able to listen to music using XMMS. Since I've upgraded I've tried using grip to listen to CDs. I don't get an error but I don't get any sound either.

Thanks.

dsharp
17th August 2004, 09:30 PM
Now that you mention it, I think I did have a problem with my sound when I first installed Redhat 8. The details are kind of fuzzy but, I think I downloaded and installed something called oss that had a driver for my sound card. I don't know if this helps but here's what is in my modprobe.conf file.

alias parport_lowlevel parport_pc
alias eth0 3c59x
alias usb-controller uhci-hcd
alias snd-card-0 cs4232
install sound-slot-2 /sbin/modprobe --first-time --ignore-install sound-slot-2 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-2 { /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time --ignore-remove sound-slot-2

Is there anything there that helps?

Thanks.

dsharp
17th August 2004, 09:59 PM
Also, saw the following in `dmesg`:

isapnp: Scanning for PnP cards...
isapnp: Card 'CS4236B'
isapnp: 1 Plug & Play card detected total

I think the CS4236B is my sound card.

I hope this helps.
Thanks.

ghaefb
18th August 2004, 10:21 AM
I see....
It looks like OSS supports your sound card -> http://www.opensound.com/osshw.html

So you need to install OSS(Open Sound System).
OSS has been replaced by ALSA(Advanced Linux Sound System) with new 2.6 kernel.
So new Linux distributions usually use ALSA insted of OSS(deprecated)
I think your sound card would work on FC1.(kernel 2.4)

I'm not sure how to install OSS and configure it...
Sory, maybe someone else has some experience ?

dsharp
18th August 2004, 04:37 PM
OK. Maybe this is a dumb question...but here goes. If I had it installed before the upgrade isn't it still installed? Is it common in linux for software to stop working when you upgrade? This is my first attempt at a linux upgrade and everything went smoothly except for the sound problem I'm having.

I visited the oss web site and they want you to pay for it now. I can download a trail copy just to see if it works. But, like I said, I thought I already had it installed.

Thanks again for all the help. I really appreciated it.

Mr.tea
24th August 2004, 10:44 AM
Hi ghaofb,
I have a similar sound problem. My sound card can be detected by system-config-soundcard and I can hear the testing sound. Even I can hear a .wav file when I move my mouse over the icon. To my surprised, I can play the wav file by recorder in the menu. And I can't hear anything when I were playing MP3 or CD.
I am a newbie to FC2.

My box is ADM 2500+ 80GB 512M ; soundcard: AC97
Can you shed some light on that?
Thanks,

imdeemvp
24th August 2004, 10:50 AM
Mr. tea you said you can hear sounds and that is good but you cant play mp3's....

fc2 has an issue with xmms needing a plugin to play mp3's not follow this instructions for xmms (http://fedoraguide.org/fc2/fc2beginnersguide.html#yummp3xmms) and if you continue to have issue with xmms use ZINF (http://www.fedoraforum.org/forum/showthread.php?t=1307)

dsharp
25th August 2004, 03:21 PM
Just to let everyone know, I installed the trail copy of the OSS drivers and my sound is working again. I'm not sure how long the trail is but I probably have sound for at least 30 days.

Psquared
1st September 2004, 09:26 PM
Just to let everyone know, I installed the trail copy of the OSS drivers and my sound is working again. I'm not sure how long the trail is but I probably have sound for at least 30 days.

Interesting. I went to their site and they offer support for my Audigy card too, but it looks like ALSA does not. (don't know the difference between Audigy Platinum and others) Yet I have both on my system. Paying for software from something that calls itself, "Open Source Sound" grates on me, but if that is what it takes I guess I will have to.