PDA

View Full Version : Freeglut (filename) failed to open display



StevieB
6th December 2008, 05:58 PM
I’ve been trying to set the $DISPLAY variable at runlevel 3 and have not be able to.
Here is the story. I’ve been trying to load Nvidia’s CUDA onto a fresh install of FC8-64 (2.6.23.1.42.fc8) on a Elite P4900M-T motherboard that has onboard video. The graphic card is a GTX 280. I am new to Linux having just abandoned Bill Gate so I’m definitely Linux knowledge handicapped.

Nvidia’s CUDA must be run without xterm and runlevel 3 satisfies that requirement. I tried running the examples but didn't get any graphics output. I debugged the examples and got the error message: freeglut (filename) failed to open display. Tried to load freeglut but RPM said it was already loaded. Checked Nvidia’s forums and Googled the error message. All seem to agree that the $DISPLAY variable is not set. Checked it at runlevel 5 and got the correct output “:0.0”. Tried it at runlevel 3 and it returned null. Tried to set it with export $DISPLAY=:0.0 and Linux shot back “=:0.0 not a valid identifier”. I tried rebooting with the BIOS set to the onboard video and with it set to the PCI-E slot. No difference. I tried reinstalling Linux twice (no CUDA each time) and rebooting with the BIOS set to the onboard video and with it set to the PCI-E slot. Again, no difference. I did see one error message that said something to the effect: Gtk warning failed to open display. The monitor is connected to the GTX 280. The onboard video seems to be deactivated by installing a card in the PCI-E slot as was not able to get any video from it.

Every variant of export $DISPLAY that I have tried gets rejected at runlevel 3. Can anyone tell me where I am going wrong?



The answer is: declare -x DISPLAY:=0.0

akje
19th March 2009, 10:21 AM
Hey,
have you tried switching to runlevel 5? X is as far as I can tell not enabled in runlevel 3.

switch to runlevel 5 by typing :
init 5

then try configuring your display again. I would try using
system-config-display

Hope this helps.

-Andreas