PDA

View Full Version : Fedora 10. KDE cannot start.



ftuser
3rd December 2008, 12:44 PM
Helo!
When I try to start KDE I receive an error:
#startkde

Could not start kstartupconfig4. Check your installation.
kstartupconfig4: symbol lookup error: /usr/lib/libQtDBus.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv
What to do?
$uname -rso

Linux 2.6.27.5-117.fc10.i686 GNU/Linux
$rpm -qa|grep qt


qtparted-0.4.5-18.fc9.i386
scim-qtimm-0.9.4-11.fc10.i386
qt-qsa-devel-1.1.5-5.fc9.i386
qtpfsgui-1.9.2-2.fc10.i386
PackageKit-qt-0.3.9-4.fc10.i386
qt-postgresql-4.4.3-2.fc10.i386
dbus-qt-0.70-4.fc9.i386
qt3-config-3.3.8b-17.fc10.i386
qtiplot-0.9-8.fc9.i386
qt-4.4.3-2.fc10.i386
qt3-MySQL-3.3.8b-17.fc10.i386
qt-odbc-4.4.3-2.fc10.i386
qt3-3.3.8b-17.fc10.i386
pinentry-qt-0.7.4-5.fc9.i386
qt-qsa-1.1.5-5.fc9.i386
dbus-qt3-0.9-1.fc10.i386
qt3-ODBC-3.3.8b-17.fc10.i386
qt-recordmydesktop-0.3.7.2-2.fc10.noarch
qt3-designer-3.3.8b-17.fc10.i386
avahi-qt3-0.6.22-11.fc10.i386
qt-devel-4.4.3-2.fc10.i386
scim-bridge-qt-0.4.15-8.fc10.i386
dbus-qt3-devel-0.9-1.fc10.i386
qt3-PostgreSQL-3.3.8b-17.fc10.i386
qwtplot3d-qt4-0.2.7-6.fc9.i386
qtoctave-0.8.1-0.20080823.svn165.fc10.i386
qt3-sqlite-3.3.8b-17.fc10.i386
dbus-qt-devel-0.70-4.fc9.i386
poppler-qt4-0.8.7-1.fc10.i386
qt4-theme-quarticurve-0.0-0.13.beta8.fc10.i386
qt-mysql-4.4.3-2.fc10.i386
qt-doc-4.4.3-2.fc10.i386
qt3-devel-3.3.8b-17.fc10.i386
qt3-devel-docs-3.3.8b-17.fc10.i386
qt-x11-4.4.3-2.fc10.i386

$rpm -qa|grep kde

kde-filesystem-4-20.fc10.noarch
kdelibs-4.1.3-3.fc10.i386
kdeartwork-extras-4.1.3-2.fc10.i386
kde-settings-pulseaudio-4.1-4.20081031svn.fc10.noarch
kdegames-libs-4.1.3-1.fc10.i386
kdeartwork-4.1.3-2.fc10.i386
kdemultimedia-libs-4.1.3-1.fc10.i386
kdebase-runtime-4.1.3-1.fc10.i386
kdebase-4.1.3-2.fc10.i386
kdegraphics-libs-4.1.3-2.fc10.i386
kdegames-4.1.3-1.fc10.i386
kdepim-4.1.3-1.fc10.i386
kdebase-workspace-libs-4.1.3-6.fc10.i386
kdenetwork-4.1.3-1.fc10.i386
solar-kde-theme-0.1.16-2.fc10.noarch
kdebase-runtime-libs-4.1.3-1.fc10.i386
kde-l10n-Russian-4.1.3-1.fc10.noarch
kdeartwork-kxs-4.1.3-2.fc10.i386
kdeutils-4.1.3-1.fc10.i386
lockdev-1.0.1-13.fc10.i386
kdelibs3-3.5.10-1.fc10.i386
kdepimlibs-4.1.3-1.fc10.i386
kdepim-libs-4.1.3-1.fc10.i386
kdeaccessibility-4.1.3-1.fc10.i386
kde-i18n-Russian-3.5.10-1.fc10.noarch
kdelibs-common-4.1.3-3.fc10.i386
kdenetwork-libs-4.1.3-1.fc10.i386
kdeplasma-addons-4.1.3-1.fc10.i386
kdebase-libs-4.1.3-2.fc10.i386
kdebase-workspace-4.1.3-6.fc10.i386
kde-settings-4.1-4.20081031svn.fc10.noarch
kde-settings-kdm-4.1-4.20081031svn.fc10.noarch
kdegraphics-4.1.3-2.fc10.i386
kdemultimedia-4.1.3-1.fc10.i386

ftuser
5th December 2008, 10:43 AM
up:rolleyes:

rdieter
6th December 2008, 08:00 PM
You likely have a rogue/foreign copy of qt(4) installed. Install any 3rd party software lately? (at one time, skype was guilty of doing this, maybe still is).

rdieter
6th December 2008, 08:02 PM
For example, look at /etc/ld.so.conf and /etc/ld.so.conf.d/* entries for locations containing libQtCore.so.4

ftuser
6th December 2008, 11:42 PM
Solved. Thanks for idea.:)
The problem was because of a rpm package pkiclient-full-4.55-34.i386.rpm from the etoken aladdin software.