View Full Version : Suspend fails on Fedora 10

2nd December 2008, 05:09 PM
Suspend worked on Fedora 9 with no problems at all. I just upgraded to F10. The trouble is when I try to suspend, pm-suspend starts, user space stuff is suspended just fine, then suspend hangs up for about 10 or so seconds, then resume kicks in.

I've tried to unload various modules which doesn't seem to help. I've also tried it without X running, same results.

When I check /var/log/pm-suspend.log , I have noticed the following and I am not sure what to do with this information:

Tue Dec 2 08:49:47 MST 2008: performing suspend
/usr/lib/pm-utils/pm-functions: line 259: echo: write error: Resource temporarily unavailable

Anybody have an idea?

By the way I am using a lenovo X60 tablet.



3rd December 2008, 11:39 AM
it happens the same for me. I was running fglrx on F9 while here is radeon driver with AIGLX on. I tried also 'pm-suspend --quirk-radeon-off', found on http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-try.html
In my understanding, this problem is related to graphic cards only because it fails running up the screen and freeze at that step of the recovery process. With ATI driver for F10 i'm almost sure it will be solved (at least for me...).

[ All this problems are very annoying for Fedora but of course every new release improve much on low level controls so if we love Fedora we love also every little question, and I do love it. To me there's also some fun in resolving problem! ]

Toshiba M50-176, Centrino 2.00Ghz, 1G DDR2
ATI Radeon X600 SE

10th December 2008, 09:50 PM
I blacklisted the following module: vmhgfs, it seems to be nothing but trouble.

Also, I yum upgraded to the latest kernel:

I hope this works for someone else.


11th December 2008, 04:00 PM
I don't have that module so I think it's not involved. I'm trying to update kernel.


15th December 2008, 03:55 AM
Try checking your Power Management Setting on your computers BIOS.

In mine, "Re-call VGA Bios from S3" was set to "Auto". Setting it to "Enabled" seems to have fixed the problem.

18th December 2008, 10:50 AM
I've not tried it, but it used to work perfectly with F9, F8, etc., with some "soft tweaking". My guess is BIOS is not the problem, at least until O.S. has the ability to change the BIOS config or smth. changed during my last update.
Notice today recovery from suspend, with the new kernel mentioned above, did work! this randomness is crazy... Mybe some process stops the recovery? I have troubles with operapluginwrapper, which sometimes freezes. I will try to kill it every time I suspend. The second difference is that this time I did recovery with power from battery, not from line. Maybe related?

3rd January 2009, 08:18 AM
i have same problem with f10
my computer shutdown when i press suspend but when start it see a white page

my graphic card is ATI RADEON X550

i sure this problem is dependent to my graphic card
see f10 bug list .f10 has problem with this graphic driver

3rd January 2009, 10:04 AM
Suspend works fine after some updates. Random crash in recovery is still present but few times.
Kernel :, xorg-x11-server-utils-7.4-3.fc10.i386
Xorg : xorg-x11-server-Xorg-1.5.3-6.fc10.i386
Ati driver : xorg-x11-drv-ati-6.9.0-63.fc10.i386
My /etc/X11/xorg.conf :

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"


Section "ServerFlags"
Option "AIGLX" "on"

Section "InputDevice"

# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"

Section "Device"
Identifier "Videocard0"
Driver "radeon"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24

Section "Extensions"
Option "Composite" "Enable"

29th January 2009, 03:24 PM
I also am unable to suspend on a ThinkPad X60. There are some good debugging tips at http://www.mjmwired.net/kernel/Documentation/power/basic-pm-debugging.txt (well, there is probably a better page somewhere, but that was the first useful thing I found.)

I booted into text mode (3) but wasn't able to suspend there either.

I tried unloading all my modules (from a GUI, I'll try it in text mode next) and things still didn't work. BTW, if people are interested, here is a probably bad way to automatically try to unload all the modules that are loaded:

# lsmod | cut -f 1 -d ' ' | while read line; do echo unloading $line; rmmod $line; done

I also have intermittent problems connecting to my WEP2 wireless (the Atheros Communications Inc. AR5212 802.11abg NIC randomly craps out) but that is a different problem.