PDA

View Full Version : X Server Error When Starting Fedora Core 2



svoltmer
14th August 2004, 10:11 AM
I get this error when the Desktop starts up in Fedora2.

"Error activating XKB configuration.
Probably internal X server problem."

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

svoltmer
15th August 2004, 01:31 AM
Fixed Myself.

kikker46
17th August 2004, 05:42 PM
How did you fix this ?

Newbie myself ...

svoltmer
17th August 2004, 05:57 PM
These are the default XKB settings for XFree86 in your XF86Config-4 file (located at; /etc/X11/). I Deleted the line: Option "XkbRules" "xfree86"

# Option "XkbRules" "xfree86"
# Option "XkbModel" "pc101"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

# Option "XkbDisable"

Option "XkbRules" "xfree86"
Option "XkbModel" "microsoft"
Option "XkbLayout" "us"

kikker46
17th August 2004, 06:40 PM
I mean real new to linux, I just installed much of it all .

I touch this is xorg.conf, but the line you specified isn't there.

I only got this error when I logg on with a not ROOT user.

svoltmer
18th August 2004, 04:13 PM
This is a fix only if you have XFree86 installed to use your ATI display drivers.
The file to alter is only: "XF86Config-4".