PDA

View Full Version : Can not create initrd.img file for F10 on USB disk drive



cenomanien
1st December 2008, 10:09 PM
Hello,

I moved my laptop internal disk drive to a USB enclosure.
This disk (external by now) is partionned as follows :

# fdisk -l /dev/sdb

Disk /dev/sdb: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x69f807c0

Device Boot Start End Blocks Id System
/dev/sdb1 1 243 1951866 1b Hidden W95 FAT32
/dev/sdb2 * 244 2155 15358140 7 HPFS/NTFS
/dev/sdb3 2156 3461 10490445 83 Linux
/dev/sdb4 3462 12161 69882750 5 Extended
/dev/sdb5 3462 3723 2104483+ 82 Linux swap / Solaris
/dev/sdb6 3724 8947 41961748+ 83 Linux
/dev/sdb7 8948 10253 10490413+ 83 Linux
/dev/sdb8 10254 12161 15325978+ 83 Linux

This disk contains an up-to-date F10 64-bit on /dev/sdb7 from which I want to be able to boot (keeping in mind that my laptop can boot from an USB disk drive).

In order to do so, I booted from the Fedora-10-x86_64-DVD in rescue mode; then chrooted to /dev/sdb7 mounted on /mnt/sysimage and tried to modify the /boot/initrd.img file to my needs :

# mkinitrd --with-usb --preload=ehci-hcd --preload=uhci-hcd --preload=ohci-hcd --preload=usb-storage --preload=scsi_mod --preload=sd_mod /boot/initrdusb.img 2.6.27.5-117.fc10.x86_64

I can not locate the newly created initrdusb.img in /boot nor anywhere. It seems that the mkinitrd command does not create any file.
I tried the mkinitrd command without the --with-usb option to no avail.

I am stuck now with no initrd.img file created !
Anybody with an idea on how to come unstuck ?

Cheers

feduser09
8th June 2009, 12:45 PM
I am facing exactly the same problem when installing fedora 10 on external USB drive. Kindly reply if anybody has answers to this problem.

cenomanien
9th June 2009, 09:58 AM
I am facing exactly the same problem when installing fedora 10 on external USB drive. Kindly reply if anybody has answers to this problem.

I eventually managed to generate a working initrd_usb_disk.img from a running Fedora 10 x86_64 installation.
You need an up-to-date system (i.e. mkinitrd).

If no success, explain what you are doing - I very much doubt you have exactly the same problem (same disk, same kernel, etc.).

Cheers

feduser09
22nd June 2009, 01:15 PM
Thanks a lot for the immediate reply. I managed to install F10 without creating a mkinitrd image . After failing with mkinitrd creation, i moved to grub setup to hd0. and it fedora booted into text mode. Then i solved the issue with nvidia drivers and finally booted into fedora. Thanks a ton for your timely asistance.