PDA

View Full Version : Trying to install brasero on fedora 7 (for my students)



bookie
29th November 2008, 01:40 PM
Hi again:) I am having a bit of bother trying to set up a scenario for my students to test their knowledge regarding dowloading and installing from command line.

My problem is we have only fedora 7 to work with at the moment and I have already pointed out to my students that if they install Fedora at home they should update to 9 or 10 if they want support and keep up to date with everything.

I am trying to install brasero-8.0.3 - but can't get very far:confused: I don't mind giving my students a few problems to solve.....but must solve them myself first...LOL:D

Anyway, two packages come up as not being installed and they are gstreamer and gstreamer-plugins. If i try to install the latest brasero - I had this error and suggestion.




Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively you may set the environment variables BRASERO_GSTREAMER_CFLAGS. See the pkg-config man page for more details.




OK! Well, I had the following missing according to brasero config:




no package ´gstreamer-0.10´found
no package ´gstreamer-plugins-base-0.10´found




I also saw that it wanted gstreamer-0.15 to work. Well, I checked the version installed and I have gstreamer-0.10.13. So, my first thought was to update the gstreamer but thought I would try and older version of brasero and see if I could match the dependencies that way. I tried all versions back to brasero-0.7.91. They all required gstreamer-0.10.15...so I went further back and took brasero-0.7.90.....and suddenly they wanted gstreamer-0.6?!!!

At the moment I am uncertain how I can solve this so my students don't waste the whole lesson problem solving....LOL

The reason for taking a src package was to get my students used to ./configure, make, and make install.

Has anyone any suggestions how to adjust the variables so that I can get the latest package to work? If not, can anyone suggest a way of solving this so the students can see the finished product working.

Much appereciate any help or suggestions I can get on this.

bookie

leigh123linux
29th November 2008, 02:07 PM
Try installing the development files


su
yum install gstreamer*devel

Hlingler
29th November 2008, 02:10 PM
(1) You have not stated so, but it is obvious that you are attempting to compile brasero from source code.
(2) Therefore, according to the error messages, you need gstreamer development files and headers. These usually come in packages named, for example: gstreamer-devel, gstreamer-plugins-devel, etc. Alternatively, you would need to acquire the source code for gstreamer and compile it (which could start an ugly chain of code dependencies cascading...).

V

bookie
29th November 2008, 02:11 PM
Hi leigh123@linux :)

Thanks for the quick reply! I will give that a go and see what develops.


bookie

bookie
29th November 2008, 04:37 PM
Hi Hlingler:) thanks for stopping by!

I have now installed the development files as suggested by leigh123@linux - but I am still being asked for gstreamer-0.10.15.

This time I had a message:




Requested ´gstreamer-0.10>=0.10.15´but version of GStreamer is 0.10.13



So, I guess we are making progress:eek: I am wondering what the next step can be? At the moment I am still in the realms of my students' overall course and would like to get this to work. Is there an update to gstreamer that I can get to statisfy the dependencies?


bookie

leigh123linux
29th November 2008, 04:46 PM
As F7 is old try compiling a older source .

http://ftp.gnome.org/pub/GNOME/sources/brasero/0.7/

bookie
29th November 2008, 04:55 PM
Hi leigh123@linux:) thanks for stopping by again! I was just sitting thinking the same thing;). Now that I have the development package installed ...then maybe it might work with an older version.

OK I will get on with that and report later.

Thanks again.

bookie

bookie
29th November 2008, 06:45 PM
Hi again:( not getting anywhere fast here!

Tried looking for an earlier version and chose brasero-0.7.1 but that needed libnautilus-burn. I ran a yum whatprovides libnautilus-burn* and got nautilus-cd-burner.

I did a check and found that already installed, so I downloaded and installed devel file for that. I now have other problems when I run configure!!

now the request is for gtk+-2.0>=2.11.6. I do not see any end to this at the moment. I don't expect a long term solution - just one that allows my students the chance to compile and see results of their work.

I am wondering if I am going to get more and more dependency problems?

bookie