PDA

View Full Version : unable to view nfs exports



nspmangalore
21st November 2008, 04:07 PM
i have 2 linux hosts, shyamlaptop and shyampc.

on shyamlaptop...


[nspmangalore@shyamlaptop ~]$ sudo /usr/sbin/showmount -e localhost
Password or swipe finger:
Export list for localhost:
/media/Extra/share *.localdomain

[nspmangalore@shyamlaptop ~]$ sudo mount localhost:/media/Extra/share /mnt
Password or swipe finger:
mount.nfs: Unknown error 521


on shyampc...


[nspmangalore@shyampc ~]$ sudo /usr/sbin/showmount -e shyamlaptop
Password:
[nspmangalore@shyampc ~]$ sudo mount shyamlaptop:/media/Extra/share /mnt
mount.nfs: mount to NFS server 'shyamlaptop' failed: timed out, retrying
mount.nfs: mount to NFS server 'shyamlaptop' failed: timed out, retrying
mount.nfs: mount to NFS server 'shyamlaptop' failed: timed out, retrying
mount.nfs: mount to NFS server 'shyamlaptop' failed: timed out, retrying
mount.nfs: mount to NFS server 'shyamlaptop' failed: timed out, giving up


why?
let me know if you need more info.
Thanks for any help in advance....

dantux
27th February 2009, 04:52 AM
Hi, did you get your issue solved?

I'm having pretty much the same problem and I can't seem to find a solution.

Thanks.

nspmangalore
27th February 2009, 05:58 AM
hi dantux,

I never tested this after I had the issue.

When I try today (now upgraded from fedora9 to fedora10, and many NFS upgrades),
I do not get that error 521 on the server (shyamlaptop).

However from the remote client (shyampc), it's still the same. :(

dantux
27th February 2009, 06:08 AM
Thanks for your reply.

I fixed it by modifying the /etc/exports file to include "insecure" option.
I also added "all_squash".
Now it works.

Here is my exports file:

[root@Fedora ~]# cat /etc/exports
/storage *(ro,all_squash,insecure,async)
/home/dantux/Public *(ro,all_squash,insecure,async)

Hope this will help others.

Thanks