PDA

View Full Version : PME Error- Fedora Won't Boot



Shadowofthesun
21st November 2008, 06:18 AM
Hey everyone:

I'm currently running Fedora 9 x86_64 on an Intel Core 2 Duo-powered Laptop. Specs are at bottom.

I'm typing this on 2.6.26.6-79.fc9.x86_64, for the simple reason that neither of the 2.6.27 series kernels I have installed will boot in a consistent manner. 2.6.27.5-37 booted once, successfully; 2.6.27.5-41 will not boot at all.

With quiet boot enabled, the kernel arguments print at the top, and then the messages "Kernel Alive" and "Kernel Really Alive" print in the bottom left of the screen. The screen freezes at this point and will not progress.

With quiet boot disabled, a handful of messages print (very few), before a series of messages appear. They are a series of messages which end with the lines "PME not supported" "PME suppored by D0 Dhot Dcold", alternating. The messages end with "PME not supported" by itself. The boot process ends at this point.

It has come to the point where my Fedora install is virtually unusable. I'm hanging on to the last kernel I have that still boots consistently (2.6.26.6-79).

Any ideas? I believe PME stands for Power Management Event, although I could be wrong (I often am :p).

Hardware:
F9 2.6.26.6-79.fc9.x86_64
Dual Boot with Vista x64
Core 2 Duo T7100
nVidia 8600M GT w/ 177.82 installed manually
3 GB RAM
250 GB HDD w/ 95 GB Free Space

Thanks in advance to all you linux gurus :)

dhimes
24th November 2008, 04:05 PM
I'm having this problem with amd turion 64. I can't use the previous kernels, either, except in terminal mode. I get to the point of "Red Hat nash version 6.0.52 starting" and then the "Kernel alive" and "Kernel really alive" just before the kernel apparently dies.

dhimes
24th November 2008, 07:55 PM
yep, it fails. And I have no more ethernet connection through a wire. Hmmmm.

dhimes
26th November 2008, 12:36 PM
As I indicated here http://forums.fedoraforum.org/showthread.php?t=205003, I removed 6.27 off-line, and let nvidia akmod rebuild both the ethernet driver and the video driver.

Shadowofthesun
1st December 2008, 05:23 AM
Ah, interesting solution... Akmods just might do it, I remember the issues started about after I told fedora to stop updating the nvidia driver and installed a driver manually...

This problem is quite frustrating, as it will not let me install Fedora 10- the install DVD hits the same error when I tell it to install.

Any other ideas?

dhimes
1st December 2008, 02:29 PM
I suspect the akmods weren't working properly, and erroneously built the drivers for both ethernet and the video. But, that's just a swag. I'm hoping they will be updated.

My f-10 liveCD choked also, by the way. I'm not sure why as I didn't have too much time to play with it.

Shadowofthesun
1st December 2008, 07:48 PM
I got the installation DVD to boot by changing xorg.conf to use vesa (not sure if this affected the install process in any way, but seemed to help), and then pretty much rebooted over and over for about 15 minutes before one of the boots randomly succeeded and I was able to continue with the full reformat of my system. I know, not the most elegant solution, but it got me to a completed install...

I just hope that whatever was giving me these PME errors was on the driver or configuration level, and therefore was cleared by the reformat. Otherwise, if its a hardware issue, I'll be stuck without a booting kernel...

dhimes
1st December 2008, 10:59 PM
rebooted over and over for about 15 minutes before one of the boots randomly succeeded and I was able to continue with the full reformat of my system

Yours are made of brass for sure!

Shadowofthesun
2nd December 2008, 01:03 AM
The problem goes deeper than I thought.

Reformatting DID NOT fix the problem. If you are having this problem, DO NOT REFORMAT. I lost access to the only kernel that would boot for me.

I'm looking into other solutions.


Bit more info for people:
**NOTE** I am now lead to believe the following is perfectly normal and has no connection to why I won't boot. I have left it on purely for chronological purposes, to show when my computer hangs during bootup.


With debug mode enabled, the output looks something like this:

pci 0000:00:xx.x: PME# supported from D- D3hot D3cold
pci 0000:00:xx.x: PME# disabled
repeat through a number of iterations, before hitting:


pci: 0000:00:1f.0: quirk: region 1000-107f claimed by ICH6 ACPI/GPIO/TCO
pci: 0000:00:1f.0: quirk: region 1180-11bf claimed by ICH5 GPIO


This is the new part: After that, the following prints:



PCI: 0000:00:1f.1 reg 10 io port: [0,7]
PCI: 0000:00:1f.1 reg 14 io port: [0,3]
PCI: 0000:00:1f.1 reg 18 io port: [0,7]
PCI: 0000:00:1f.1 reg 1c io port: [0,3]


Similar things print for 0000:00:1f.2, before the lines:

PCI: 0000:00:1f.2 reg 24 32bit mmio: [f8404000, f84047ff]
,followed again by the PME lines above (Specific to 0000:00:1f.2).

Finally, lines print for 0000:00:1f.3 and 0000:01:00.0 talking about 32big mmio, io port, 64bit mmio, and then nothing else prints beyond this point.



Sorry for another edit, but I stumbled upon this while googling:
http://www.gossamer-threads.com/lists/linux/kernel/987833?page=last

This doesn't help me much, seeing as I don't have a booting kernel, but it might help others with my problem.

Shadowofthesun
2nd December 2008, 04:57 AM
Success-

Appending noaciptimer to the end of the kernel boot arguments in GRUB sent me safely through the boot process.

Now I just have to figure out why I'm booting to a black screen instead of either a CLI or a GUI, and I'm back in business :p

magnusk
2nd December 2008, 11:03 PM
I have the same problem with FC10 not booting on my Zepto 6224W. When booting from install DVD I get a PME error. Also tried booting from a live-CD but that does not work either.

hamvui85
8th January 2009, 05:03 PM
i have a same problem. Althougt, i have installed Fedora 9 finished.

Shadowofthesun
8th January 2009, 11:42 PM
hamvui85:

I have resolved the issue by adding nolapic to the boot loader.

Give that a shot and report back.