PDA

View Full Version : Setting NTFS Hard Drive Permissions



yuiol
10th August 2004, 10:54 PM
I recenttly mounted my NTFS hard drive wich my Windows OS is on. I used this command in the terminal as root to mount it "mount -t ntfs /dev/hda1 /mnt/windows"

When I try to access the files it says I don't have permission. The group and owner of the folder is set to "root" and the only way I can access it is if I log in as root. Can anyone help me on setting permsions so I can access it on my account? Thanks.

Spudgun
10th August 2004, 10:57 PM
As 'root':

chown username /mnt/windows/*

yuiol
10th August 2004, 11:13 PM
I used that command and it gave me this,
"chown: changing ownership of `/mnt/windows': Read-only file system"

But I still can't access the folder

imdeemvp
10th August 2004, 11:29 PM
your post has been answer correctly....i just want ot comment chown means change ownership :D

yuiol
10th August 2004, 11:53 PM
Ya so I changed the ownership to my account, but I still can't access it from the account I changed it to. Why is this?

Hellme
11th August 2004, 12:08 AM
chown doesn't work, setting umask to anything from 0000 to 0222 doesn't work, right click properties > permissions doesn't work. Nothing works. To top things off, umount doesn't work in most cases - it just says 'drive is busy'. I've made sure all windows relating to the mounted volume are closed - is there a kill signal I can pass to all processes related to a mounted volume?

Does ANYONE know how to set permissions on mounted NTFS drives so that root Linux can create directories and files?

imdeemvp
11th August 2004, 12:12 AM
did you updated to the new kernel....you may need to install new nfts.rpm according to kernel

foolish
11th August 2004, 12:29 AM
NTFS and Fat32 permissions are handled by adding umask flags when mounting. umask=000 is equal to chmod 777 on all files on the drive, not wise security wise. Read up on umask to get a better setting.

Hellme
11th August 2004, 12:35 AM
Updated the kernel. I can mount the NTFS drive without a glitch, and I don't mind setting the CHMOD to 777 because its a practically empty drive that intend to use as a shuttle between XP and FC2 (i.e store mutually accessible data and then 'shuttle' it to wherever it should reside permanently). What concerns me is even 0000 (i.e. CHMOD 777) doesn't work. Does anyone know why?

lof
29th August 2004, 05:33 PM
Try this: as root go to your /etc/fstab and add this line:
/dev/hda1 /mnt/windows ntfs ro,umask=0222 0 0

Reboot and you'll be able to access /mnt/windows as a normal user.

Then say how it gone.