PDA

View Full Version : FS compatability issues



ToFue
16th November 2008, 05:43 AM
Humph.. - I'm stumped!

Okay, I have XP64 installed as NTFS on the second partition of my SATA drive(sda0; d:\; while c:\ is Program files)
I also have Fedora9 x64 installed with ext3 as separate partitions ( "/", "/root", "/home", "/etc" etc... ;p) on my IDE drive (hda0, etc..) as the primary slave, with DVD-Rom as the master.

Each install works well and stable when that OS's drive is connected *alone*.

Problem:
#1 When I attempt to use XP with the Linux drive is still installed, XP then crashes to a blue-screen shortly after login.

#2 When Logged into Fedora, I can "see" the windows partitions with no problem as icons, except that they won't officially mount, even if I try to force- It gives me an error about the disk still being in use; that it didn't "shut down properly" or .. stuff..

Steps taken:
For problem #1 I've installed the freeware Ext2 IFS For Windows (http://www.fs-driver.org/download.html), achieving the same results (apparently after hardware scan), except that the blue-screen only flashes up before system reboots; The problem remains.

I've attempted to resolve problem #2 by making the NTFS drives(partitions) I'm attempting to access under Fedora marked as "shared" from the XP side..

My goal:
Simply for the two to live in harmony; that I can synchronize music, netbeans projects, audio projects & plugins, and "sandbox" files, etc, as well as any other reason I would want to dual boot for.. :D

Anyway, I would truly appreciate a guru's helping mind that can point me to the right solutions!

Thanx!

jwj
16th November 2008, 08:11 AM
In the motherboard's bios make sure the hard drive with windows has the first boot priority. This would mean it would also have the MBR.

ToFue
17th November 2008, 10:20 PM
First, Thanks for the reply! :D

Yes- this is the case. When I boot to XP, it has to be first in boot priority (the sata drive with MS MBR), or it will go to grub when both OS drives are connected.

In the case of an XP boot windows will load fine up to login, after the user is already logged in, the crash will occur while/after all the background process load.

In the case of the Fedora boot, I have to move the IDE drive with Grub as the boot priority.
Fedora boots without issue, but the windows drive is inaccessible, but "visible" as desktop icons.

I can boot into the OS'- they just don't play nice with each other without me having to either physically disconnect the Fedora IDE drive from the mobo to work in xp, or going through BIOS every time I switch back to Fedora and reconnect the IDE drive.

It seems that these two problems are possibly related... Is it possible that XP sees another boot partition-that it doesn't know it's <language> or perhaps swap..? Is it a 64-bit conflict between the filesystems..? <sigh again>

JohnVV
17th November 2008, 11:16 PM
so i take it you did mot install fedora's grub in the MBR , but in the first fedora partition
then ran the " dd of=/dev/sdb? if=/......" then copied" fedora.bin to the windows" C:\\ drive) than edited the windows boot.ini and added c:\\fedora.bin " fedora"

how did you set up the duel boot ?

jwj
18th November 2008, 01:34 AM
or it will go to grub when both OS drives are connected.
That's what you want. Grub will act as a temporary boot manager and allow you to chooses between windows and fedora. Assuming grub.conf is set up right there should be a menu of choices.

ToFue
19th November 2008, 05:36 AM
jwj has it- I can boot into windoze from grub, or (with a choice of two kernel versions) into Fedora 9.. Just couldn't boot with fedora still attached if I wanted to get into windows without windows crashing.. and the BROD error was device driver related according to the error reporter

I think I found out what was going on.. XP never liked acknowledging ext2/ext3 parts and xp64 simply went straight into a crash if it discovered ext*- which is what prompted me to install the "Ext2 IFS For Windows" program.. after install I restarted but system hung, not fully registering the program with xp, and the sys crashed again, so I pulled the IDE(fedora) cable and rebooting without error into xp, but set all ntfs partitions to share. Restarting hung yet again, and I then booted instead to Fedora(IDE reconnected at this point), still unable to access the partitions- they were still flagged as mounted by windows, without having a successful windows shutdown. I eventually restarted XP w/out the IDE attached and shutdown "properly", and while switching over to Fedora one more time, saw that the drives were mounted (diff icons to indicate that). So, I then rebooted into windows from grub again, and it seems that windows finally took the "Ext2 IFS For Windows" prog.. <sigh> What a run-around!

Thanks guys! I truly appreciate the assistance!! ::beams::

jwj
20th November 2008, 02:19 AM
I'm glad it worked out. However

but set all ntfs partitions to share.
Setting the share value for a windows directory will have no effect on what you are trying to do.
Shares are a topic related to a local network. If you had 2 different computers connected with a home router then you might want to enable some shares.
I was under the impression that fedora automatically mounted just about everything in the /media folder. I might be wrong about that but you should take a look. /media is one of the upper level directories like /bin, /boot, /etc and /home. If not you can mount the ntfs with the mount command or make a entry in /etc/fstab.

JohnVV
20th November 2008, 02:54 AM
fedora 9 has ntfs-3g installed by default so any ntfs windows partitions will auto mount to /media
and there should be a desktop icon for that windows drive .
also i do believe that xp can not boot vista but vista can boot xp
so the install order for your 3 os box would be
XP -- it's bootloader overwrote by vista
Vista -- it's boot loader in MBR
Fedora -- Grub is able to boot vista ( unless vista is hardware encrypted ) then vista's bootloader must be used

ToFue
20th November 2008, 07:52 PM
I'm glad it worked out. However

Setting the share value for a windows directory will have no effect on what you are trying to do.
Shares are a topic related to a local network.

Yeah- I tried it while troubleshooting. I guess it was hope more than logic.. What was happening was that ntfs-3g would attempt to mount, but by having no successful shutdown in xp, xp didn't 'release' permissions/use of those NTFS partitions causing them to be flagged as still in use- so ntfs-3g couldn't mount all the way.. :p

Again, thanks guys!