PDA

View Full Version : Cannot update, yum problems.



Xero
15th November 2008, 04:48 AM
Apologies in advance if in wrong section, just sounded most likely place. Finally got adsl on the other day, been stuck on dialup til now, so been unable to do full update. Anyway, aftrer setting up system as per one of the fedoraguide, I went to run a full update now that i have enough bandwidth, and am encountering a problem, which hopefully one more knowledgable than me will be able to help me with. :)


[root@Xero Download]# yum update
Loaded plugins: fastestmirror, fedorakmod, kernel-module, presto, protectbase,
: refresh-packagekit
Setting up and reading Presto delta metadata
No Presto metadata available for rpmfusion-nonfree-updates
No Presto metadata available for fedora
No Presto metadata available for rpmfusion-free-updates
No Presto metadata available for rpmfusion-free
No Presto metadata available for updates-newkey
No Presto metadata available for updates
No Presto metadata available for rpmfusion-nonfree
No Presto metadata available for livna
Loading mirror speeds from cached hostfile
* rpmfusion-nonfree-updates: mirror.transact.net.au
* fedora: ftp.iinet.net.au
* rpmfusion-free-updates: mirror.transact.net.au
* rpmfusion-free: mirror.transact.net.au
* updates-newkey: ftp.iinet.net.au
* updates: ftp.iinet.net.au
* rpmfusion-nonfree: mirror.transact.net.au
* livna: ftp-stud.fht-esslingen.de
4 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package evolution.i386 0:2.22.3.1-1.fc9 set to be updated
---> Package gvfs-fuse.i386 0:0.2.5-1.fc9 set to be updated
---> Package perl-devel.i386 4:5.10.0-38.fc9 set to be updated
---> Package perl-libwww-perl.noarch 0:5.816-1.fc9 set to be updated
---> Package NetworkManager-gnome.i386 1:0.7.0-0.11.svn4022.4.fc9 set to be updated
--> Processing Dependency: NetworkManager = 1:0.7.0-0.11.svn4022.4.fc9 for package: NetworkManager-gnome
---> Package lame-libs.i386 0:3.98.2-2.fc9 set to be updated
---> Package xorg-x11-drv-openchrome.i386 0:0.2.903-1.fc9 set to be updated
---> Package logwatch.noarch 0:7.3.6-26.fc9 set to be updated
---> Package xorg-x11-server-Xorg.i386 0:1.5.0-2.fc9 set to be updated
---> Package libmad.i386 0:0.15.1b-8.fc9 set to be updated
---> Package xmlto.i386 0:0.0.20-3.fc9 set to be updated
---> Package a2ps.i386 0:4.14-5.fc9 set to be updated
--> Processing Dependency: html2ps for package: a2ps
---> Package xorg-x11-drv-nvidia-libs.i386 0:173.14.12-2.fc9 set to be updated
---> Package openldap-clients.i386 0:2.4.10-2.fc9 set to be updated
---> Package xorg-x11-drv-nv.i386 0:2.1.10-2.fc9 set to be updated
---> Package samba-winbind.i386 0:3.2.4-0.21.fc9 set to be updated
---> Package xorg-x11-drv-vmmouse.i386 0:12.6.1-1.fc9 set to be updated
---> Package smolt.noarch 0:1.1.1.1-8.fc9 set to be updated
---> Package setroubleshoot-plugins.noarch 0:2.0.11-1.fc9 set to be updated
---> Package foomatic.i386 0:3.0.2-67.fc9 set to be updated
---> Package NetworkManager-vpnc.i386 1:0.7.0-0.10.svn4024.fc9 set to be updated
---> Package perl-ExtUtils-ParseXS.i386 1:2.18-38.fc9 set to be updated
---> Package libquicktime-utils.i386 0:1.0.3-3.fc9 set to be updated
---> Package system-config-firewall.noarch 0:1.2.10-1.fc9 set to be updated
---> Package gnome-python2-bonobo.i386 0:2.22.1-2.fc9 set to be updated
--> Processing Dependency: vcdimager >= 0.7.23 for package: xine-lib-extras-freeworld
--> Processing Dependency: vcdimager for package: devede
---> Package pyxdg.noarch 0:0.16-1.fc9 set to be updated
---> Package libxml2-devel.i386 0:2.7.2-1.fc9 set to be updated
---> Package xorg-x11-drv-glint.i386 0:1.2.1-1.fc9 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.0-0.11.svn4022.4.fc9 set to be updated
---> Package faad2-libs.i386 1:2.6.1-5.fc9 set to be updated
---> Package mplayer-gui.i386 0:1.0-0.98.20080903svn.fc9 set to be updated
--> Processing Dependency: libliveMedia.so.0 for package: mplayer-gui
--> Processing Dependency: libBasicUsageEnvironment.so.0 for package: mplayer-gui
--> Processing Dependency: libUsageEnvironment.so.0 for package: mplayer-gui
--> Processing Dependency: libgroupsock.so.0 for package: mplayer-gui
---> Package libacl-devel.i386 0:2.2.47-2.fc9 set to be updated
---> Package perl-Test-Harness.i386 0:2.64-38.fc9 set to be updated
--> Processing Dependency: libmpeg2.so.0 for package: gstreamer-plugins-ugly
--> Processing Dependency: libmpeg2.so.0 for package: mpeg2dec
--> Processing Dependency: libmpeg2.so.0 for package: vlc-core
--> Processing Dependency: libmpeg2convert.so.0 for package: mpeg2dec
---> Package xmms-faad2.i386 1:2.6.1-5.fc9 set to be updated
---> Package a52dec.i386 0:0.7.4-13.fc9 set to be updated
---> Package rpmdevtools.noarch 0:6.7-1.fc9 set to be updated
---> Package hal.i386 0:0.5.11-2.fc9 set to be updated
---> Package devede.noarch 0:3.11b-2.fc9 set to be updated
---> Package xorg-x11-drv-mga.i386 0:1.4.9-1.fc9 set to be updated
---> Package kmod-nvidia.i686 0:173.14.15-1.fc9.3 set to be updated
--> Processing Dependency: kmod-nvidia-2.6.27.5-37.fc9.i686 = 173.14.15-1.fc9.3 for package: kmod-nvidia
---> Package ffmpeg-libs.i386 0:0.4.9-0.48.20080908.fc9 set to be updated
---> Package python-devel.i386 0:2.5.1-26.fc9 set to be updated
---> Package xine-lib-extras-freeworld.i386 0:1.1.15-4.fc9 set to be updated
---> Package nautilus.i386 0:2.22.5.1-1.fc9 set to be updated
---> Package pycairo.i386 0:1.4.12-3.fc9 set to be updated
---> Package bluez-utils-alsa.i386 0:3.35-5.fc9 set to be updated
---> Package bluez-utils.i386 0:3.35-5.fc9 set to be updated
---> Package perl-libs.i386 4:5.10.0-38.fc9 set to be updated
---> Package perl.i386 4:5.10.0-38.fc9 set to be updated
---> Package selinux-policy-targeted.noarch 0:3.3.1-107.fc9 set to be updated
---> Package gnome-applets.i386 1:2.22.3-1.fc9 set to be updated
---> Package bluez-utils-cups.i386 0:3.35-5.fc9 set to be updated
---> Package vlc-core.i386 0:0.9.6-1.fc9 set to be updated
--> Processing Dependency: libschroedinger-1.0.so.0 for package: vlc-core
--> Processing Dependency: libzvbi.so.0 for package: vlc-core
---> Package yum-utils.noarch 0:1.1.17-1.fc9 set to be updated
---> Package gnome-system-monitor.i386 0:2.22.4-1.fc9 set to be updated
---> Package libquicktime.i386 0:1.0.3-3.fc9 set to be updated
---> Package

Xero
15th November 2008, 04:48 AM
alsa-utils.i386 0:1.0.17-2.fc9 set to be updated
---> Package mpeg2dec.i386 0:0.5.1-3.fc9 set to be updated
---> Package pulseaudio-esound-compat.i386 0:0.9.10-2.fc9 set to be updated
---> Package system-config-date.noarch 0:1.9.32-1.fc9 set to be updated
---> Package samba-client.i386 0:3.2.4-0.21.fc9 set to be updated
---> Package yum-metadata-parser.i386 0:1.1.2-9.fc9 set to be updated
---> Package selinux-policy.noarch 0:3.3.1-107.fc9 set to be updated
---> Package faad2.i386 1:2.6.1-5.fc9 set to be updated
---> Package mp3gain.i386 0:1.4.6-5.fc9 set to be updated
---> Package authconfig-gtk.i386 0:5.4.4-1.fc9 set to be updated
---> Package gstreamer-ffmpeg.i386 0:0.10.5-1.fc9.1 set to be updated
---> Package x264-libs.i386 0:0.0.0-0.15.20080613.fc9 set to be updated
---> Package gnome-mplayer.i386 0:0.9.1-1.fc9 set to be updated
---> Package gdm.i386 1:2.22.0-10.fc9 set to be updated
---> Package glib2-devel.i386 0:2.16.6-2.fc9 set to be updated
---> Package bittorrent.noarch 0:4.4.0-7.fc9 set to be updated
---> Package gimp.i386 2:2.4.7-3.fc9 set to be updated
---> Package bluez-gnome.i386 0:0.26-1.fc9 set to be updated
---> Package mpg321.i386 0:0.2.10.4-2.fc9 set to be updated
---> Package xorg-x11-drv-nvidia.i386 0:173.14.12-2.fc9 set to be updated
---> Package smolt-firstboot.noarch 0:1.1.1.1-8.fc9 set to be updated
---> Package xorg-x11-drv-i810.i386 0:2.3.2-3.fc9 set to be updated
---> Package gstreamer-plugins-ugly.i386 0:0.10.8-2.fc9 set to be updated
---> Package tkinter.i386 0:2.5.1-26.fc9 set to be updated
---> Package at.i386 0:3.1.10-24.fc9 set to be updated
---> Package xorg-x11-drv-vesa.i386 0:2.0.0-1.fc9 set to be updated
---> Package perl-Module-Pluggable.i386 1:3.60-38.fc9 set to be updated
---> Package perl-IO-Compress-Zlib.i386 0:2.008-38.fc9 set to be updated
---> Package perl-Compress-Raw-Zlib.i386 0:2.008-38.fc9 set to be updated
---> Package docbook-utils.noarch 0:0.6.14-14.fc9 set to be updated
---> Package vcdimager-libs.i386 0:0.7.23-8.fc9 set to be updated
---> Package perl-suidperl.i386 4:5.10.0-38.fc9 set to be updated
---> Package system-config-printer.i386 0:0.7.82.5-1.fc9 set to be updated
---> Package perl-Params-Validate.i386 0:0.91-1.fc9 set to be updated
---> Package streamripper.i386 0:1.62.3-8.fc9 set to be updated
---> Package libsmbclient.i386 0:3.2.4-0.21.fc9 set to be updated
---> Package perl-ExtUtils-MakeMaker.i386 0:6.36-38.fc9 set to be updated
---> Package twolame-libs.i386 0:0.3.12-3.fc9 set to be updated
---> Package policycoreutils-gui.i386 0:2.0.52-8.fc9 set to be updated
--> Processing Dependency: selinux-policy-devel for package: policycoreutils-gui
---> Package xvidcore.i386 0:1.1.3-4.fc9 set to be updated
---> Package system-config-network-tui.noarch 0:1.5.10-1.fc9 set to be updated
---> Package openldap-devel.i386 0:2.4.10-2.fc9 set to be updated
---> Package samba-common.i386 0:3.2.4-0.21.fc9 set to be updated
---> Package vnc.i386 0:4.1.2-31.fc9 set to be updated
---> Package gstreamer-plugins-bad.i386 0:0.10.7-4.fc9 set to be updated
--> Processing Dependency: libofa.so.0 for package: gstreamer-plugins-bad
---> Package ffmpeg-compat.i386 0:0.4.9-0.48.20080225.fc9 set to be updated
---> Package docbook-utils-pdf.noarch 0:0.6.14-14.fc9 set to be updated
---> Package libdvbpsi.i386 0:0.1.6-3.fc9 set to be updated
---> Package gnome-python2-gnomevfs.i386 0:2.22.1-2.fc9 set to be updated
---> Package perl-Pod-Simple.i386 1:3.07-38.fc9 set to be updated
---> Package setroubleshoot.noarch 0:2.0.8-2.fc9 set to be updated
---> Package faac.i386 0:1.25-7.fc9 set to be updated
---> Package cvs.i386 0:1.11.22-14.fc9 set to be updated
---> Package docbook-dtds.noarch 0:1.0-38.fc9 set to be updated
---> Package gnome-python2-gconf.i386 0:2.22.1-2.fc9 set to be updated
---> Package pam-devel.i386 0:1.0.1-4.fc9 set to be updated
---> Package mplayer.i386 0:1.0-0.98.20080903svn.fc9 set to be updated
---> Package gdm-user-switch-applet.i386 1:2.22.0-10.fc9 set to be updated
---> Package sudo.i386 0:1.6.9p13-7.fc9 set to be updated
---> Package xmms-mp3.i386 0:1.2.11-2.20071117cvs.fc9 set to be updated
---> Package samba.i386 0:3.2.4-0.21.fc9 set to be updated
---> Package ghostscript.i386 0:8.63-1.fc9 set to be updated
---> Package liferea.i386 0:1.4.18-1.fc9 set to be updated
---> Package kmod-nvidia-2.6.26.6-79.fc9.i686.i686 0:173.14.12-6.fc9.2 set to be updated
---> Package xorg-x11-drv-mutouch.i386 0:1.2.1-1.fc9 set to be updated
---> Package libcurl-devel.i386 0:7.18.2-6.fc9 set to be updated
---> Package libdca.i386 0:0.0.5-3.fc9 set to be updated
---> Package xorg-x11-drv-savage.i386 0:2.2.0-2.fc9 set to be updated
---> Package xorg-x11-drv-elographics.i386 0:1.2.3-1.fc9 set to be updated
---> Package gecko-mediaplayer.i386 0:0.9.0-1.fc9 set to be updated
---> Package thoggen.i386 0:0.7.1-2.fc9 set to be updated
---> Package docbook-style-xsl.noarch 0:1.73.2-10.fc9 set to be updated
---> Package setroubleshoot-server.noarch 0:2.0.8-2.fc9 set to be updated
---> Package perl-version.i386 3:0.74-38.fc9 set to be updated
---> Package xorg-x11-drv-synaptics.i386 0:0.15.1-3.fc9 set to be updated
---> Package gvfs.i386 0:0.2.5-1.fc9 set to be updated
---> Package livna-config-display.noarch 0:0.0.22-1.fc9 set to be updated
---> Package pilot-link.i386 2:0.12.3-14.fc9 set to be updated
---> Package eog.i386 0:2.22.3-1.fc9 set to be updated
---> Package unrar.i386 0:3.7.8-3.fc9 set to be updated
---> Package libmms.i386 0:0.4-3.fc9 set to be updated
--> Processing Dependency: perl = 4:5.10.0-20.fc9 for package: perl-Pod-Escapes
---> Package system-config-firewall-tui.noarch 0:1.2.10-1.fc9 set to be updated
---> Package mencoder.i386 0:1.0-0.98.20080903svn.fc9 set to be updated
---> Package gnome-python2.i386 0:2.22.1-2.fc9 set to be updated
---> Package xorg-x11-drv-geode.i386 0:2.10.1-1.fc9 set to be updated
---> Package vlc.i386 0:0.9.6-1.fc9 set to be updated
--> Processing Dependency: libcvaux.so.1 for package: vlc
--> Processing Dependency: libml.so.1 for package: vlc
--> Processing Dependency: libfluidsynth.so.1 for package: vlc
--> Processing Dependency: libcv.so.1 for package: vlc
--> Processing Dependency: libQtCore.so.4 for package: vlc
--> Processing Dependency: libhighgui.so.1 for package: vlc
--> Processing Dependency: libcxcore.so.1 for package: vlc
--> Processing Dependency: libQtGui.so.4 for package: vlc
---> Package evolution-help.i386 0:2.22.3.1-1.fc9 set to be updated
---> Package hal-info.noarch 0:20080607-1.fc9 set to be updated
---> Package BackupPC.noarch 0:3.1.0-3.fc9 set to be updated
---> Package system-config-network.noarch 0:1.5.10-1.fc9 set to be updated
---> Package perl-IO-Compress-Base.i386 0:2.008-38.fc9 set to be updated
---> Package netpbm-progs.i386 0:10.35.48-1.fc9 set to be updated
---> Package xine.i386 0:0.99.5-4.fc9 set to be updated
---> Package mjpegtools-libs.i386 0:1.9.0-0.6.rc3.fc9 set to be updated
---> Package gnome-python2-canvas.i386 0:2.22.1-2.fc9 set to be updated
---> Package docbook-slides.noarch 0:3.4.0-4.fc9 set to be updated
---> Package ntp-perl.i386 0:4.2.4p5-2.fc9 set to be updated
---> Package xorg-x11-drv-ati.i386 0:6.8.0-19.fc9 set to be updated
---> Package python-numeric.i386 0:24.2-11.fc9 set to be updated
---> Package docbook-simple.noarch 0:1.1-4.fc9 set to be updated
---> Package screen.i386 0:4.0.3-12.fc9 set to be updated
---> Package NetworkManager-openvpn.i386 1:0.7.0-16.svn4027.fc9 set to be updated
---> Package ffmpeg2theora.i386 0:0.21-2.fc9 set to be updated
---> Package perl-Compress-Zlib.i386 0:2.008-38.fc9 set to be updated
---> Package system-config-printer-libs.i386 0:0.7.82.5-1.fc9 set to be updated
---> Package hal-cups-utils.i386 0:0.6.16-4.fc9 set to be updated
--> Running transaction check
---> Package html2ps.noarch 0:1.0-0.1.b5.fc9 set to be updated
--> Processing Dependency: perl(Image::Magick) for package: html2ps
---> Package NetworkManager.i386 1:0.7.0-0.11.svn4022.4.fc9 set to be updated
---> Package libmpeg2.i386 0:0.5.1-3.fc9 set to be updated
---> Package fluidsynth-libs.i386 0:1.0.8-1.fc9 set to be updated
--> Processing Dependency: lash for package: fluidsynth-libs
--> Processing Dependency: liblash.so.1 for package: fluidsynth-libs
---> Package vcdimager.i386 0:0.7.23-8.fc9 set to be updated
---> Package kmod-nvidia-2.6.27.5-37.fc9.i686.i686 0:173.14.15-1.fc9.3 set to be updated
--> Processing Dependency: kernel-uname-r = 2.6.27.5-37.fc9.i686 for package: kmod-nvidia-2.6.27.5-37.fc9.i686
--> Processing Dependency: nvidia-kmod-common >= 173.14.15 for package: kmod-nvidia-2.6.27.5-37.fc9.i686
---> Package schroedinger.i386 0:1.0.3-2.fc9 set to be updated
---> Package opencv.i386 0:1.0.0-8.fc9 set to be updated
---> Package zvbi.i386 0:0.2.30-1.fc9 set to be updated
---> Package live555.i386 0:0-0.20.2008.07.25.fc9 set to be updated
---> Package libofa.i386 0:0.9.3-13.fc9 set to be updated
--> Processing Dependency: libfftw3.so.3 for package: libofa
---> Package qt-x11.i386 1:4.4.3-1.fc9 set to be updated
---> Package selinux-policy-devel.noarch 0:3.3.1-107.fc9 set to be updated
---> Package qt.i386 1:4.4.3-1.fc9 set to be updated
--> Processing Dependency: perl = 4:5.10.0-20.fc9 for package: perl-Pod-Escapes
--> Running transaction check
---> Package kmod-nvidia-2.6.27.5-37.fc9.i686.i686 0:173.14.15-1.fc9.3 set to be updated
--> Processing Dependency: kernel-uname-r = 2.6.27.5-37.fc9.i686 for package: kmod-nvidia-2.6.27.5-37.fc9.i686
--> Processing Dependency: nvidia-kmod-common >= 173.14.15 for package: kmod-nvidia-2.6.27.5-37.fc9.i686
---> Package lash.i386 0:0.5.4-2.fc9 set to be updated
--> Processing Dependency: perl = 4:5.10.0-20.fc9 for package: perl-Pod-Escapes
---> Package fftw.i386 0:3.1.2-6.fc9 set to be updated
---> Package ImageMagick-perl.i386 0:6.3.8.1-4.fc9 set to be updated
--> Processing Conflict: python-devel conflicts python < 2.5.1-26.fc9

Xero
15th November 2008, 04:49 AM
--> Finished Dependency Resolution
kmod-nvidia-2.6.27.5-37.fc9.i686-173.14.15-1.fc9.3.i686 from rpmfusion-nonfree-updates has depsolving problems
--> Missing Dependency: kernel-uname-r = 2.6.27.5-37.fc9.i686 is needed by package kmod-nvidia-2.6.27.5-37.fc9.i686-173.14.15-1.fc9.3.i686 (rpmfusion-nonfree-updates)
kmod-nvidia-2.6.27.5-37.fc9.i686-173.14.15-1.fc9.3.i686 from rpmfusion-nonfree-updates has depsolving problems
--> Missing Dependency: nvidia-kmod-common >= 173.14.15 is needed by package kmod-nvidia-2.6.27.5-37.fc9.i686-173.14.15-1.fc9.3.i686 (rpmfusion-nonfree-updates)
python-devel-2.5.1-26.fc9.i386 from updates-newkey has depsolving problems
--> python-devel conflicts with python
1:perl-Pod-Escapes-1.04-20.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-20.fc9 is needed by package 1:perl-Pod-Escapes-1.04-20.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-20.fc9 is needed by package 1:perl-Pod-Escapes-1.04-20.fc9.i386 (installed)
Error: python-devel conflicts with python
Error: Missing Dependency: nvidia-kmod-common >= 173.14.15 is needed by package kmod-nvidia-2.6.27.5-37.fc9.i686-173.14.15-1.fc9.3.i686 (rpmfusion-nonfree-updates)
Error: Missing Dependency: kernel-uname-r = 2.6.27.5-37.fc9.i686 is needed by package kmod-nvidia-2.6.27.5-37.fc9.i686-173.14.15-1.fc9.3.i686 (rpmfusion-nonfree-updates)
[root@Xero Download]#

A bit stuck, so any ideas/suggestions are appreciated. until this pothole in the road, have been quite enjoying my experience with Fedora 9, but would like to fully update my system, and this is preventing me from doing so. Thanks in advance. :)

edit: broken up, as it won't let me post all at once.

Jake
15th November 2008, 04:51 AM
Try cleaning all.

yum clean all.

If not, make sure you have all repositorys enabled, besides development, and debug source etc.

If not type this:

yum remove kmod-nvidia* python-devel perl-Pod-Escapes

Then straight after. do not reboot until these work properly, and your updated fully.

yum install kmod-nvidia* python-devel perl-Pod-Escapes

marko
15th November 2008, 06:33 AM
I had the same problem, I think it was because I had rolled my own yum repo file for using presto, commenting out

baseurl=http://dl.anmar.eu.org/repos/f$releasever/updates-$basearch.newkey
and switching back to
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever.newkey&arch=$basearch

fixed it

n3t
15th November 2008, 06:44 AM
Mine done that untill i ran yum clean-all from the terminal.. If you're using yumex to update it could also be a problem because when i used it the new kernel didn't show up and i was having a depends issue because the new kernel wasn't installed. I talked to the other guy up there and he said the kernel was in reg updates so i then went to my term and ran the clean cmd and checked the updates and it was there. I then ran yum update from the term and everything went fine. I havn't booted it yet but it showed to install fine.

Xero
15th November 2008, 09:24 AM
I've tried several of the suggestions here, but nothing seems to be working. Am considering whether to reinstall, and hoping this is just a glitch, and not something that will occur again. *shrug* I'll give it til later today, see if can't work it out, but a reinstall is looking likely.