PDA

View Full Version : Problem with YUM Extender



Trel
14th November 2008, 11:04 PM
When I try to run it, I get this error



1.
Error Type: <class 'yum.update_md.UpdateNoticeException'>
2.
Error Value: No id element found
3.
File : /usr/share/yumex/yumex.py , line 737, in <module>
4.
mainApp = YumexApplication()
5.
File : /usr/share/yumex/yumex.py , line 446, in __init__
6.
self.setupYum()
7.
File : /usr/share/yumex/yumex.py , line 467, in setupYum
8.
self.yumbase._setupBase()
9.
File : /usr/share/yumex/yumapi.py , line 80, in _setupBase
10.
self._setupUpdateMetadata()
11.
File : /usr/share/yumex/yumapi.py , line 137, in _setupUpdateMetadata
12.
self.updateMetadata.add(repo)
13.
File : /usr/lib/python2.5/site-packages/yum/update_md.py , line 319, in add
14.
un = UpdateNotice(elem)
15.
File : /usr/lib/python2.5/site-packages/yum/update_md.py , line 69, in __init__
16.
self._parse(elem)
17.
File : /usr/lib/python2.5/site-packages/yum/update_md.py , line 146, in _parse
18.
raise UpdateNoticeException("No id element found")


I already tried yum clean metadata

sidebrnz
14th November 2008, 11:17 PM
I've been having the same trouble today, so it's not at your end, or at mine. I'm guessing it's at one or more of the repos, and we'll be seeing an announcement about it RSN.

ningbojoe
15th November 2008, 09:59 AM
I am having the same problem as well. I hope that this can be addressed ASAP.

Ujeen
15th November 2008, 12:19 PM
the same stuff here

ningbojoe
16th November 2008, 02:22 AM
This thread seems to fix this problem.
http://forums.fedoraforum.org/showthread.php?t=204203