PDA

View Full Version : Flash video sound inoperative



RotogenRay
14th November 2008, 08:51 PM
I've got fedora 9 on my hp pavillion a1632x amd64 (quad core)
still trying to get everything configured

on firefox, first, I had no flash.

so I used this information:

http://hacktux.com/fedora/9/flash

and tried swfdec and gnash.

well, that didn't work, so I went about trying to get sdobe flash player to work. The instructions from that page didn't work, but after this:
http://docs.fedoraproject.org/release-notes/f9/en_US/sn-Desktop.html

aha! videos work
but no sound

well after figuring out that my speakers were unplugged, I realized
theres still no sound.

I put libflashsupport on here, still nothing.

I uninstalled and reinstalled flash player and libflashsuppot- still nothing.

I wouldn't come here unless I had nowhere else to go- and thats pretty much the point I'm at.

The sound does work on my system... just not in firefox

help?

phinger
14th November 2008, 09:07 PM
Have you tried the excellent script by dangermouse to install practically all of
the 'basic' needs ?
You can find it here:

http://forums.fedoraforum.org/showthread.php?t=171660

Hope this helps...

P

vallimar
15th November 2008, 03:01 PM
You need to provide more info or read the (many) previous threads on the subject.

Firefox.x86_64 with flash 10 -- Working for me is having these:

alsa-lib 32 & 64
nspluginwrapper 32 & 64

With flash 10, libflashsupport is not used, remove it.
Remove all of gnash and swfdec if installed, they are useless (at least in x64).

Those 4 will install many required packages.
On 64bit Firefox with Flash 10, alsa-lib.i386 is necessary.
Maybe pulse-libs.i386 too if you use pulse, I don't so I don't have it.

Optional: run "mozilla-plugin-config -f -i"

pwca
15th November 2008, 06:01 PM
You mention that this only occurs in Firefox. As such there is the possibility that one of your extentions (e.g. AdBlock Plus, NoScript, etc...) is blocking the website from:

a) loading the flash video
and/or
b) starting the javascript necessary to process the sound.

Try adjusting the settings in Firefox preferences and any of these extensions you may have installed.

p.s. this advice is in addition to the two previous posters suggestions as those things need to be done as well.